aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/fping/fping_3.5.bb
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2013-09-08 17:52:11 +0300
committerJoe MacDonald <joe@deserted.net>2013-09-13 12:48:55 -0700
commit138f44f9bbd37fc86596a14a2b541597eee27ae4 (patch)
tree016598470213b894dc480d6399056ff10e9978e4 /meta-networking/recipes-support/fping/fping_3.5.bb
parenta506a9efc86cda9dbf36cd916dbbfb1ae2162c45 (diff)
downloadmeta-openembedded-contrib-138f44f9bbd37fc86596a14a2b541597eee27ae4.tar.gz
fping: add recipe
Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-support/fping/fping_3.5.bb')
-rw-r--r--meta-networking/recipes-support/fping/fping_3.5.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/fping/fping_3.5.bb b/meta-networking/recipes-support/fping/fping_3.5.bb
new file mode 100644
index 0000000000..fe8893405e
--- /dev/null
+++ b/meta-networking/recipes-support/fping/fping_3.5.bb
@@ -0,0 +1,25 @@
+SUMMARY = "sends ICMP ECHO_REQUEST packets to network hosts"
+DESCRIPTION = "fping is a ping like program which uses the Internet Control \
+Message Protocol (ICMP) echo request to determine if a target host is \
+responding. fping differs from ping in that you can specify any number of \
+targets on the command line, or specify a file containing the lists of \
+targets to ping. Instead of sending to one target until it times out or \
+replies, fping will send out a ping packet and move on to the next target \
+in a round-robin fashion."
+HOMEPAGE = "http://www.fping.org/"
+SECTION = "console/tools"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=09d77789fe32be35acde9637a5ee39b1"
+
+SRC_URI = "http://www.fping.org/dist/fping-${PV}.tar.gz"
+SRC_URI[md5sum] = "2e17cb655aa4eb59b5a4a38a89e746ed"
+SRC_URI[sha256sum] = "09b8960e235341bae6000085d38106357eae656a79e0119bd27e816c9003656a"
+
+S = "${WORKDIR}/fping-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-ipv4"
+
+PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"