aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtdb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-11-25 10:44:45 +0800
committerKhem Raj <raj.khem@gmail.com>2021-11-25 10:14:18 -0800
commit301e8045d2472fb93040c0dc0a44e534a08b182e (patch)
treee52543d1a4cdc1ab533d64124b00a7fbee1d6c96 /meta-networking/recipes-support/libtdb
parent13187d3f014c50b011c3704a484c7e00e9c31de9 (diff)
downloadmeta-openembedded-contrib-301e8045d2472fb93040c0dc0a44e534a08b182e.tar.gz
libtdb: fix pyext_PATTERN for cross compilation
The pyext_PATTERN will add native arch as suffix when cross compiling. For example, on qemuarm64, it is expanded to: pyext_PATTERN ='%s.cpython-310-x86_64-linux-gnu.so' which will result in the incorrect library name. root@qemuarm64:~# find /usr/lib/python3.10/ -name tdb\* /usr/lib/python3.10/site-packages/tdb.so /usr/lib/python3.10/site-packages/tdb.cpython-310-x86_64-linux-gnu.so Set pyext_PATTERN to '%s.so' to remove the suffix. After the patch: root@qemuarm64:~# find /usr/lib/python3.10/ -name tdb\* /usr/lib/python3.10/site-packages/tdb.so Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/libtdb')
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb/0001-Fix-pyext_PATTERN-for-cross-compilation.patch42
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb_1.4.3.bb7
2 files changed, 43 insertions, 6 deletions
diff --git a/meta-networking/recipes-support/libtdb/libtdb/0001-Fix-pyext_PATTERN-for-cross-compilation.patch b/meta-networking/recipes-support/libtdb/libtdb/0001-Fix-pyext_PATTERN-for-cross-compilation.patch
new file mode 100644
index 0000000000..6f221989fa
--- /dev/null
+++ b/meta-networking/recipes-support/libtdb/libtdb/0001-Fix-pyext_PATTERN-for-cross-compilation.patch
@@ -0,0 +1,42 @@
+From 00bd6680ad38c20c95a35c963d7077269f3a3aa2 Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Wed, 24 Nov 2021 13:33:35 +0800
+Subject: [PATCH] Fix pyext_PATTERN for cross compilation
+
+The pyext_PATTERN will add native arch as suffix when cross compiling.
+For example, on qemuarm64, it is expanded to:
+pyext_PATTERN ='%s.cpython-310-x86_64-linux-gnu.so'
+which will result in the incorrect library name.
+
+root@qemuarm64:~# find /usr/lib/python3.10/ -name tdb\*
+/usr/lib/python3.10/site-packages/tdb.so
+/usr/lib/python3.10/site-packages/tdb.cpython-310-x86_64-linux-gnu.so
+
+Set pyext_PATTERN to '%s.so' to remove the suffix.
+After the patch:
+root@qemuarm64:~# find /usr/lib/python3.10/ -name tdb\*
+/usr/lib/python3.10/site-packages/tdb.so
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ third_party/waf/waflib/Tools/python.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/third_party/waf/waflib/Tools/python.py b/third_party/waf/waflib/Tools/python.py
+index 7c45a76..c9a90f7 100644
+--- a/third_party/waf/waflib/Tools/python.py
++++ b/third_party/waf/waflib/Tools/python.py
+@@ -328,7 +328,7 @@ def check_python_headers(conf, features='pyembed pyext'):
+ x = 'MACOSX_DEPLOYMENT_TARGET'
+ if dct[x]:
+ env[x] = conf.environ[x] = dct[x]
+- env.pyext_PATTERN = '%s' + dct['SO'] # not a mistake
++ env.pyext_PATTERN = '%s.so'
+
+
+ # Try to get pythonX.Y-config
+--
+2.17.1
+
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.4.3.bb b/meta-networking/recipes-support/libtdb/libtdb_1.4.3.bb
index ad84593893..e7f7384025 100644
--- a/meta-networking/recipes-support/libtdb/libtdb_1.4.3.bb
+++ b/meta-networking/recipes-support/libtdb/libtdb_1.4.3.bb
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c
SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
file://tdb-Add-configure-options-for-packages.patch \
+ file://0001-Fix-pyext_PATTERN-for-cross-compilation.patch \
"
SRC_URI[md5sum] = "e638e8890f743624a754304b3f994f4d"
@@ -39,12 +40,6 @@ EXTRA_OECONF += "--disable-rpath \
--with-libiconv=${STAGING_DIR_HOST}${prefix}\
"
-do_install:append() {
- # add this link for cross check python module existence. eg: on x86-64 host, check python module
- # under recipe-sysroot which is mips64.
- cd ${D}${PYTHON_SITEPACKAGES_DIR}; ln -s tdb.*.so tdb.so
-}
-
PACKAGES += "tdb-tools python3-tdb"
RPROVIDES:${PN}-dbg += "python3-tdb-dbg"