aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-09-21 13:41:07 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-10-20 11:16:38 -0400
commit529171574c66b42f3b82da6fb6bda66e564851c9 (patch)
treeedbb1e002de249de0053bc467a0e244d355cc7eb /meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb
parent778a2b6793f1a30eaef325797c57d45745788b4a (diff)
downloadmeta-openembedded-contrib-529171574c66b42f3b82da6fb6bda66e564851c9.tar.gz
libtevent: fixes for deterministic builds
* Add configure option and PACKAGECONFIG for the following packages: - acl - attr - libaio - libbsd - libcap - valgrind * They are all optional, so disable by default or control them based on DISTRO_FEATURES. * Remove the direct dependency on libaio and libbsd Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb
index 222a22aa32..9f4e235c5d 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.29.bb
@@ -3,10 +3,12 @@ HOMEPAGE = "http://tevent.samba.org"
SECTION = "libs"
LICENSE = "LGPLv3+"
-DEPENDS += "libaio libbsd libtalloc"
+DEPENDS += "libtalloc"
RDEPENDS_python-tevent = "python"
-SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
+SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
+ file://tevent-Add-configure-options-for-packages.patch \
+"
LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
SRC_URI[md5sum] = "4372c1430a1ecb7ea0adddfdf21c0d55"
@@ -14,7 +16,16 @@ SRC_URI[sha256sum] = "a4f519b0bbb718fe2175bee9011ee4d199675f28c2ef80531be38e7bba
inherit waf-samba
-PACKAGECONFIG[attr] = ",,attr"
+PACKAGECONFIG ??= "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
+"
+PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
+PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
+PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
+PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
+PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
+PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"