aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtevent
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-15 16:18:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-16 21:50:10 +0100
commit0e525daafe2958504674a9910bbed7c1b4d3fd38 (patch)
treeab265ec69054c64bc7c16a7b7bb55610531d5039 /meta-networking/recipes-support/libtevent
parentdf552bed28c6ed983a94ebad4185bc9b2d04486f (diff)
downloadmeta-openembedded-contrib-0e525daafe2958504674a9910bbed7c1b4d3fd38.tar.gz
samba, ctdb, libldb, libtdb, libtevent, talloc: move to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/libtevent')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch16
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb30
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch b/meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch
new file mode 100644
index 0000000000..1ce4dda1c3
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch
@@ -0,0 +1,16 @@
+Don't check manpages for xsltproc.
+
+Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
+
+diff -Nurp tevent-0.9.21.orig/lib/talloc/wscript tevent-0.9.21/lib/talloc/wscript
+--- tevent-0.9.21.orig/lib/talloc/wscript 2013-09-08 21:24:14.000000000 +0900
++++ tevent-0.9.21/lib/talloc/wscript 2015-04-24 16:28:04.085000230 +0900
+@@ -55,7 +55,7 @@ def configure(conf):
+ if conf.env.standalone_talloc:
+ conf.env.TALLOC_COMPAT1 = Options.options.TALLOC_COMPAT1
+
+- conf.CHECK_XSLTPROC_MANPAGES()
++ conf.find_program('xsltproc', var='XSLTPROC')
+
+ if not conf.env.disable_python:
+ # also disable if we don't have the python libs installed
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
new file mode 100644
index 0000000000..f297f30e12
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
+HOMEPAGE = "http://tevent.samba.org"
+SECTION = "libs"
+LICENSE = "LGPLv3+"
+
+DEPENDS += "talloc libcap"
+RDEPENDS_${PN} += "libtalloc"
+RDEPENDS_python-tevent = "python"
+
+SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b"
+
+SRC_URI[md5sum] = "3d5a76c0a1b5f724842d785fd055633f"
+SRC_URI[sha256sum] = "f2be7463573dab2d8210cb57fe7e7e2aeb323274cbdc865a6e29ddcfb977f0f4"
+
+inherit waf-samba
+
+S = "${WORKDIR}/tevent-${PV}"
+
+EXTRA_OECONF += "--disable-rpath \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace \
+ --with-libiconv=${STAGING_DIR_HOST}${prefix}\
+ --without-gettext \
+ "
+
+PACKAGES += "python-tevent python-tevent-dbg"
+
+FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
+FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"