aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/lksctp-tools
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2021-02-04 02:34:41 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-04 09:26:39 -0800
commit974fed367e11ab453496192386df620acfb04697 (patch)
tree929e36ef520186312fbdad1f086af350bb99978c /meta-networking/recipes-support/lksctp-tools
parent4767b1ea6c4ccba4dfdaad53ed444faf22757eb2 (diff)
downloadmeta-openembedded-contrib-974fed367e11ab453496192386df620acfb04697.tar.gz
lksctp-tools: make conpatible to autoconf-2.70
... ./configure: line 16398: syntax error: unexpected end of file ... Backport a commit from upstream to fix it Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/lksctp-tools')
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch89
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb1
2 files changed, 90 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch
new file mode 100644
index 0000000000..484af4e0fa
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch
@@ -0,0 +1,89 @@
+From d6d7130f0a2e3b81880fca29966e42c1b2be40a7 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Fri, 8 Jan 2021 22:22:52 +0000
+Subject: [PATCH] m4/sctp.m4: make conpatible to autoconf-2.70
+
+On recently released `autoconf-2.70` generated `./configure`
+fails as:
+
+```
+$ ./configure
+...
+checking for struct sctp_event_subscribe.sctp_stream_reset_event... yes
+checking for gcc options needed to detect all undeclared functions... none needed
+./configure: line 16464: syntax error: unexpected end of file
+```
+
+This happens becuase new autoconf generates less whitespace:
+
+```
+{
+if ...
+...
+fi}
+```
+
+It requires at least whitespace between `fi` and `}`.
+
+As input already has newlines the change just drops extra `{}`.
+
+Tested on `autoconf-2.69` and `autoconf-2.70`.
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+Signed-off-by: Marcelo Ricardo Leitner <marcelo.leitner@gmail.com>
+
+Upstream-Status: Backport [git://github.com/sctp/lksctp-tools.git]
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+---
+ m4/sctp.m4 | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/m4/sctp.m4 b/m4/sctp.m4
+index 6593517..94527a6 100644
+--- a/m4/sctp.m4
++++ b/m4/sctp.m4
+@@ -6,7 +6,7 @@
+
+ # Macros to assist on probing kernel features
+ # Probes if a type is defined
+-AC_DEFUN([LKSCTP_CHECK_TYPE], [{
++AC_DEFUN([LKSCTP_CHECK_TYPE], [
+ AC_CHECK_TYPE([$1],
+ AC_DEFINE([$2], 1,
+ [Define if $1 is present.])
+@@ -22,10 +22,10 @@ AC_CHECK_TYPE([$1],
+ #ifdef HAVE_LINUX_SCTP_H
+ # include <linux/sctp.h>
+ #endif
+-])}])
++])])
+
+ # Probes if a struct has a given member
+-AC_DEFUN([LKSCTP_CHECK_MEMBER], [{
++AC_DEFUN([LKSCTP_CHECK_MEMBER], [
+ AC_CHECK_MEMBER([$1],
+ AC_DEFINE([$2], 1,
+ [Define if $1 is present.])
+@@ -41,10 +41,10 @@ AC_CHECK_MEMBER([$1],
+ #ifdef HAVE_LINUX_SCTP_H
+ # include <linux/sctp.h>
+ #endif
+-])}])
++])])
+
+ # Probes if a declaration is present
+-AC_DEFUN([LKSCTP_CHECK_DECL], [{
++AC_DEFUN([LKSCTP_CHECK_DECL], [
+ AC_CHECK_DECL([$1],
+ AC_DEFINE([$2], 1,
+ [Define if $1 is present.])
+@@ -60,4 +60,4 @@ AC_CHECK_DECL([$1],
+ #ifdef HAVE_LINUX_SCTP_H
+ # include <linux/sctp.h>
+ #endif
+-])}])
++])])
+--
+2.27.0
+
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb
index 1e2c644b41..f481ffee1d 100644
--- a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb
@@ -15,6 +15,7 @@ LK_REL = "1.0.18"
SRC_URI = " \
git://github.com/sctp/lksctp-tools.git \
+ file://0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch \
file://run-ptest \
file://v4test.sh \
file://v6test.sh \