aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:50 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-05 11:41:28 -0400
commit275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802 (patch)
tree4fd20a242b848ec8497066801b86706de3defdce /meta-networking/recipes-support/netcf
parent7a9c626092c7d3b10206c7ca4ea2827cca9cba4f (diff)
downloadmeta-openembedded-contrib-275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802.tar.gz
meta-networking: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/netcf')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 26c738b2cc..1bc6baef0d 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -24,7 +24,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd",
PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts,"
do_install_append() {
- if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system
if [ -d "${D}${libdir}/systemd/system" ]; then
mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/