aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf
diff options
context:
space:
mode:
authorAmarnath Valluri <amarnath.valluri@intel.com>2017-02-23 11:05:38 +0200
committerJoe MacDonald <joe_macdonald@mentor.com>2017-03-23 08:26:59 -0400
commit8bc2e7cb78342c7f07432c49cc5373c47ed0fb4d (patch)
tree380e652a2d5ce654b2dc9694bfb4b3ece34e8e63 /meta-networking/recipes-support/netcf
parent9f0eebd8294713ac3b4571a0a635ecad85d9db7f (diff)
downloadmeta-openembedded-contrib-8bc2e7cb78342c7f07432c49cc5373c47ed0fb4d.tar.gz
netcf_git: Check if src != dst while moving files.
Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/netcf')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 90c77c9f54..a7a5000e27 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -47,9 +47,11 @@ do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system
if [ -d "${D}${libdir}/systemd/system" ]; then
- mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/
- rm -rf ${D}${libdir}/systemd/
- else
+ if [ "${systemd_unitdir}" != "${libdir}/systemd" ] ; then
+ mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/
+ rm -rf ${D}${libdir}/systemd/
+ fi
+ elif [ "${systemd_unitdir}" != "${nonarch_libdir}/systemd" ] ; then
mv ${D}${nonarch_libdir}/systemd/system/* ${D}${systemd_unitdir}/system/
rm -rf ${D}${nonarch_libdir}/systemd/
fi