aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-03-18 16:21:06 +0800
committerJoe MacDonald <joe.macdonald@windriver.com>2014-03-27 15:41:13 -0400
commita600fe808a71ad569697eb4921b3d101f1c032d7 (patch)
tree7b53bd0cd41e9b936c043ce274566a1654170e3a /meta-networking/recipes-support/netcf
parentd9f21ab787c8eef2cfdc1f5408f973ebbcc196e2 (diff)
downloadmeta-openembedded-contrib-a600fe808a71ad569697eb4921b3d101f1c032d7.tar.gz
netcf: fix gnulib not found in sysroots while using a shared sstate cache
... ./bootstrap: Bootstrapping from checked-out netcf sources... ./bootstrap: consider installing git-merge-changelog from gnulib ./bootstrap: line 641: tmp/sysroots/qemux86/usr/share/gnulib/gnulib-tool: No such file or directory ... The gnulib source was incorrectly populated to ${STAGING_DATADIR}. While the build shared an existed sstate cache, the gnulib's ${SYSROOT_DESTDIR} was empty, the gnulib source code was not found in sysroots. We should use do_install task to install them to ${D}, and the default do_populate_sysroot task will populate them to ${STAGING_DATADIR}. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/netcf')
-rw-r--r--meta-networking/recipes-support/netcf/gnulib_git.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-networking/recipes-support/netcf/gnulib_git.bb b/meta-networking/recipes-support/netcf/gnulib_git.bb
index 730f5cd789..1da6c83ede 100644
--- a/meta-networking/recipes-support/netcf/gnulib_git.bb
+++ b/meta-networking/recipes-support/netcf/gnulib_git.bb
@@ -16,18 +16,15 @@ SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \
"
S = "${WORKDIR}/git"
-# Git clone a copy of gnulib source to the staging data dir
-sysroot_stage_all () {
- [ -d ${STAGING_DATADIR}/gnulib/ ] && rm -rf ${STAGING_DATADIR}/gnulib/
+do_install () {
cd ${S}
git checkout master
- git clone ${S} ${STAGING_DATADIR}/gnulib
+ git clone ${S} ${D}/${datadir}/gnulib
}
do_patch[noexec] = "1"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-do_install[noexec] = "1"
do_package[noexec] = "1"
do_packagedata[noexec] = "1"
do_package_write_ipk[noexec] = "1"