aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf
diff options
context:
space:
mode:
authorPaul Gortmaker <paul.gortmaker@windriver.com>2016-05-17 14:27:22 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-18 10:58:02 -0400
commitdf2e3bb6a3fbb56c24277d402bef895baaadcd45 (patch)
tree5ccd2d5a0467ec32158392f9c4456e170c397bde /meta-networking/recipes-support/netcf
parent8fe7d1e60b2d64079a8f9c882231c2f27fc1729b (diff)
downloadmeta-openembedded-contrib-df2e3bb6a3fbb56c24277d402bef895baaadcd45.tar.gz
netcf: unconditionally remove gnulib dir to support reconfigure
The rmdir in configure prepend seemed like a nice sanity check to ensure the upstream source didn't change their handling of the gnulib submodule, but it will be a problem when changed sigs (in gnulib for example) trigger a reconfigure in an existing build. In such an instance, the .gnulib dir will have the old copy from the sysroot, and not be empty and the rmdir will fail. Given that we don't know what changed in the context of the prepend, we just assume it could have been the gnulib sysroot content, and hence blow away the old dir and re-copy in the possibly updated gnulib sysroot content. This works for both clean builds, and rebuilds that have triggered a reconfigure of an existing netcf build. Fixes: 093942197237 ("netcf: fix mishandling of gnulib submodule causing build fail") Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/netcf')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 8d6d32a608..ed713ace28 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -28,9 +28,10 @@ do_configure_prepend() {
cd ${S}
# avoid bootstrap cloning gnulib on every configure
- # the rmdir acts as a sentinel to let us know if the pkg ever changes
- # the path for GNUlib or populates the dir making it non-empty.
- rmdir ${S}/.gnulib
+ # the dir starts out empty from the pkg, but unconditionally blow it
+ # away so if we reconfigure due to gnulib sysroot sig changes, we will
+ # get the newer gnulib content into the build here.
+ rm -rf ${S}/.gnulib
cp -rf ${STAGING_DATADIR}/gnulib ${S}/.gnulib
# --force to avoid errors on reconfigure e.g if recipes changed we depend on