aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2015-08-17 15:37:48 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2015-08-19 15:26:30 -0400
commite16d5c08766f85f673e46e37907b734eb897b628 (patch)
tree49fac2f60f889c28976a98e7c6f8ca7f86c351ee /meta-networking/recipes-support/netcf
parent91e6dc888aa6f1e09d8a032d4ce556fc45c4b5db (diff)
downloadmeta-openembedded-contrib-e16d5c08766f85f673e46e37907b734eb897b628.tar.gz
netcf: support multilib builds
When doing a multilib build, /usr/lib is still created but not collected into FILES_${PN} by default, resulting in a QA error. Adding both ${libdir} and ${nonarch_libdir} catches all scenarios. It also turns out that the previous do_install_append would throw an error in a multilib build since systemd always installs to .../lib/... but ${libdir] would point at .../lib64/... Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/netcf')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index d47bb3b03b..8a8963e44f 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -32,12 +32,22 @@ do_configure_prepend() {
do_install_append() {
if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system
- mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/
- rm -rf ${D}${libdir}/systemd/
+ if [ -d "${D}${libdir}/systemd/system" ]; then
+ mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/
+ rm -rf ${D}${libdir}/systemd/
+ else
+ mv ${D}${nonarch_libdir}/systemd/system/* ${D}${systemd_unitdir}/system/
+ rm -rf ${D}${nonarch_libdir}/systemd/
+ fi
else
mv ${D}${sysconfdir}/rc.d/init.d/ ${D}${sysconfdir}
rm -rf ${D}${sysconfdir}/rc.d/
fi
}
+FILES_${PN} += " \
+ ${libdir} \
+ ${nonarch_libdir} \
+ "
+
SYSTEMD_SERVICE_${PN} = "netcf-transaction.service"