aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ntopng/ntopng_5.0.bb
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2021-09-10 09:59:04 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-09 20:25:10 -0700
commit12dba784f65b50cdbfec6618967b9bdaa37e0e78 (patch)
tree4c011ced034a8260cad6af084ffc87371d02daba /meta-networking/recipes-support/ntopng/ntopng_5.0.bb
parent8359cf87458d185011831a8132b8af17bcbc9605 (diff)
downloadmeta-openembedded-contrib-12dba784f65b50cdbfec6618967b9bdaa37e0e78.tar.gz
ntopng: upgrade 4.2 -> 5.0
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/ntopng/ntopng_5.0.bb')
-rw-r--r--meta-networking/recipes-support/ntopng/ntopng_5.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntopng/ntopng_5.0.bb b/meta-networking/recipes-support/ntopng/ntopng_5.0.bb
new file mode 100644
index 0000000000..89107430ea
--- /dev/null
+++ b/meta-networking/recipes-support/ntopng/ntopng_5.0.bb
@@ -0,0 +1,49 @@
+SUMMARY = "Web-based Traffic and Security Network Traffic Monitoring"
+DESCRIPTION = "ntopng is a web-based network traffic monitoring application \
+released under GPLv3. It is the new incarnation of the original \
+ntop written in 1998, and now revamped in terms of performance, \
+usability, and features."
+
+SECTION = "console/network"
+
+DEPENDS = "curl libmaxminddb libpcap lua mariadb ndpi json-c rrdtool zeromq"
+RDEPENDS:${PN} = "bash redis"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRCREV = "85867090d92df4365c0af8d47f54ab3106117e59"
+SRC_URI = "git://github.com/ntop/ntopng.git;protocol=git;branch=5.0-stable \
+ file://0001-configure.seed-fix-configure-error.patch \
+ file://0001-configure.seed-fix-host-contamination.patch \
+ file://0001-Makefile.in-don-t-use-the-internal-lua.patch \
+ file://0001-autogen.sh-generate-configure.ac-only.patch \
+ file://0001-configure.seed-not-check-clang-on-host.patch \
+ file://ntopng.service \
+"
+
+S = "${WORKDIR}/git"
+
+# don't use the lua under thirdparty as it supports cross compiling badly
+export LUA_LIB = "${STAGING_LIBDIR}/liblua.a"
+
+LDFLAGS:append:mipsarch = " -latomic"
+LDFLAGS:append:powerpc = " -latomic"
+LDFLAGS:append:riscv32 = " -latomic"
+inherit autotools-brokensep gettext systemd
+
+do_install:append() {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/ntopng.service ${D}${systemd_unitdir}/system
+}
+
+FILES:${PN} += "\
+ ${systemd_unitdir}/system/ntopng.service"
+
+FILES:${PN}-doc += "\
+ /usr/man/man8/ntopng.8"
+
+do_configure:prepend() {
+ ${S}/autogen.sh
+}
+
+SYSTEMD_SERVICE:${PN} = "ntopng.service"