aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-04 15:42:15 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2016-02-29 16:23:34 -0500
commit346cc53ea34cc516de3441862884840379485008 (patch)
treebfee0b27405eba046617b6bd58a890050759e840 /meta-networking/recipes-support
parentf2729b7ab2123e0a7bf9f7f7cbdfcc5f880cdfcb (diff)
downloadmeta-openembedded-contrib-346cc53ea34cc516de3441862884840379485008.tar.gz
ntp: remove empty libexecdir to prevent potential QA issues
Depending on the configuration used to build ntp it is possible to have an empty libexecdir. This can cause QA issues. Add a test at the end of install() to remove libexecdir if it is empty, thus avoiding the possibility of QA issues, regardless of configuration. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p6.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p6.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p6.bb
index 1836dd9bc1..a7b998a661 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p6.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p6.bb
@@ -94,6 +94,9 @@ do_install_append() {
install -d ${D}${systemd_unitdir}/ntp-units.d
install -m 0644 ${WORKDIR}/ntpd.list ${D}${systemd_unitdir}/ntp-units.d/60-ntpd.list
+
+ # Remove an empty libexecdir.
+ rmdir --ignore-fail-on-non-empty ${D}${libexecdir}
}
PACKAGES += "ntpdate sntp ${PN}-tickadj ${PN}-utils"