aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-20 02:05:11 -0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-02-29 16:23:34 -0500
commit36fa2355a028e47a302b2fa723144ea3ea731fb0 (patch)
tree58c263b29a2ea38167ca49f90633905de38dbe96 /meta-networking/recipes-support
parent4ebf44dda042db55db2ae7deb7ff5acc184d59a7 (diff)
downloadmeta-openembedded-contrib-36fa2355a028e47a302b2fa723144ea3ea731fb0.tar.gz
cim-schema-exper: fix host-user-contaminated
Fixed: cim-schema-exper-2.39.0: cim-schema-exper: /cim-schema-exper/usr/share/mof/cimv2.39.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] cim-schema-final-2.40.0: cim-schema-final: /cim-schema-final/usr/share/mof/cimv2.40.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] lib32-cim-schema-exper-2.39.0: lib32-cim-schema-exper: /lib32-cim-schema-exper/usr/share/mof/cimv2.39.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] lib32-cim-schema-final-2.40.0: lib32-cim-schema-final: /lib32-cim-schema-final/usr/share/mof/cimv2.40.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] It uses cp -a to install the files, so fix the owner to root:root Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb1
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
index 62e50df1d3..e4ed7b3628 100644
--- a/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
@@ -17,6 +17,7 @@ do_install() {
install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV}
cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/
+ chown -R root:root ${D}${datadir}/mof/cimv${PV}
for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do
sed -i -e 's/\r//g' $i
done
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
index 1694f31824..7ab9c4d492 100644
--- a/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
@@ -22,6 +22,7 @@ do_install() {
install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV}
cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/
+ chown -R root:root ${D}${datadir}/mof/cimv${PV}/
for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do
sed -i -e 's/\r//g' $i
done