aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-21 10:58:08 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-21 13:06:13 +0200
commit36d57b9234c8d940205cf83e541302ef60b755c9 (patch)
tree111b53cf879e62ba22bbdb892b0589023c91f2d8 /meta-networking/recipes-support
parent0ee108356873f69229642d0c6f025f3328c5ff2f (diff)
downloadmeta-openembedded-contrib-36d57b9234c8d940205cf83e541302ef60b755c9.tar.gz
recipes: add missing pkgconfig class inherits
* These recipes all use pkg-config in some way but were missing dependencies on the tool, this patch adds them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb2
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb2
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb2
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
index 29e54c4824..f733a7832f 100644
--- a/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
@@ -13,7 +13,7 @@ SRC_URI[sha256sum] = "75592483d40dc4f76cc3b41af40caa4be80478946a699d46846d5d03e4
DEPENDS = "openssl xz zlib bzip2 libcap"
-inherit autotools
+inherit autotools pkgconfig
PACKAGECONFIG ??= " \
${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
index 5fc0de3151..d8e1ddbba2 100644
--- a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -14,7 +14,7 @@ SRCREV = "a1d9615adde6d1a568813c24a128273ed755af04"
S = "${WORKDIR}/git"
-inherit autotools python-dir
+inherit autotools python-dir pkgconfig
CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools"
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 5a301e3098..d6ca30fb65 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -16,7 +16,7 @@ DEPENDS += "augeas libnl libxslt libxml2 gnulib"
S = "${WORKDIR}/git"
-inherit gettext autotools-brokensep
+inherit gettext autotools-brokensep pkgconfig
EXTRA_OECONF_append_class-target = " --with-driver=redhat"
do_configure_prepend() {
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb b/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb
index f8116e3d07..821d965eac 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb
@@ -31,7 +31,7 @@ PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4,"
PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,"
-inherit autotools systemd
+inherit autotools systemd pkgconfig
RRECOMMENDS_${PN} = "kernel-module-ipsec"