aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorMihaela Sendrea <mihaela.sendrea@enea.com>2014-05-13 18:14:19 +0200
committerJoe MacDonald <joe@deserted.net>2014-06-03 21:18:51 -0400
commitab6a7ff9b35689013b0cd76be0c3d8455c205856 (patch)
tree911c58eab3f39973f9f3db6e0137c9882f2349e3 /meta-networking/recipes-support
parentc4ba56ceebdd0d42f90e2ec509440f105645c376 (diff)
downloadmeta-openembedded-contrib-ab6a7ff9b35689013b0cd76be0c3d8455c205856.tar.gz
lksctp-tools: add recipe (version 1.0.16)
This recipe comes from arago-oe-dev: https://github.com/mrchapp/arago-oe-dev/tree/master/recipes/lksctp-tools Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
new file mode 100644
index 0000000000..102c2bb2ee
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
@@ -0,0 +1,43 @@
+SUMMARY = "The Linux Kernel Stream Control Transmission Protocol (lksctp) project"
+SECTION = "libs"
+LICENSE = "LGPLv2"
+
+LIC_FILES_CHKSUM = " \
+ file://COPYING.lib;md5=0a1b79af951c42a9c8573533fbba9a92 \
+ file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \
+"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lksctp/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "708bb0b5a6806ad6e8d13c55b067518e"
+SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae351f26"
+
+S = "${WORKDIR}/${BP}"
+
+BBCLASSEXTEND = "native"
+
+inherit autotools pkgconfig binconfig
+
+SOLIBVERSION="${PV}"
+SOLIBMAJORVERSION="1"
+
+PACKAGES =+ "${PN}-withsctp ${PN}-utils"
+
+FILES_${PN} = " \
+ ${libdir}/libsctp.so.${SOLIBVERSION} \
+"
+
+FILES_${PN}-withsctp = " \
+ ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBVERSION} \
+"
+
+FILES_${PN}-dev += " \
+ ${libdir}/libsctp.so.${SOLIBMAJORVERSION} \
+ ${libdir}/libsctp.so \
+ ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBMAJORVERSION} \
+ ${libdir}/lksctp-tools/libwithsctp.so \
+ ${datadir}/lksctp-tools/*.c \
+ ${datadir}/lksctp-tools/*.h \
+"
+
+FILES_${PN}-utils = "${bindir}/*"