aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-22 11:45:28 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 10:23:37 -0400
commit11618db5cbee8a91af20896bc3402e46c9fb1a19 (patch)
tree36001fe48903bdba3ce9b98603f677e39bbc8771 /meta-networking/recipes-support
parent2c21aa8633e4e3538099bcc56d76ab0a594411b4 (diff)
downloadmeta-openembedded-contrib-11618db5cbee8a91af20896bc3402e46c9fb1a19.tar.gz
ctdb: Fix build with musl
Fixes | ./utils/smnotify/smnotify.h:9:10: fatal error: 'rpc/rpc.h' file not found | #include <rpc/rpc.h> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/ctdb/ctdb_2.5.6.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ctdb/ctdb_2.5.6.bb b/meta-networking/recipes-support/ctdb/ctdb_2.5.6.bb
index 7cea0f681c..b5a60645c5 100644
--- a/meta-networking/recipes-support/ctdb/ctdb_2.5.6.bb
+++ b/meta-networking/recipes-support/ctdb/ctdb_2.5.6.bb
@@ -27,6 +27,9 @@ PACKAGECONFIG[libtdb] = "--without-included-tdb,--with-included-tdb,libtdb"
PARALLEL_MAKE = ""
DEPENDS += "popt libtevent libtalloc libldb"
+DEPENDS_append_libc-musl = " libtirpc"
+CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
+LDFLAGS_append_libc-musl = " -ltirpc"
# ctdbd_wrapper requires pgrep, hence procps
RDEPENDS_${PN} += "procps"