aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2017-08-31 04:57:32 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2017-09-12 10:55:07 -0400
commit446619d5ec45f0480852a6806067c1937b95923a (patch)
tree212213572b6aae7fcf035a7798be2af3e711c995 /meta-networking/recipes-support
parent0ede604e78bc88c654b596e825b2bca1e687c398 (diff)
downloadmeta-openembedded-contrib-446619d5ec45f0480852a6806067c1937b95923a.tar.gz
drbd-utils: only rmmod if DRBD is a module
Account for the case if the DRBD drive is built into the kernel. Otherwise, errors, like the following, will occur: root@localhost:~# /etc/init.d/drbd stop Stopping all DRBD resources: ERROR: Module drbd does not exist in /proc/modules Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch39
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
new file mode 100644
index 0000000000..add0b030cf
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
@@ -0,0 +1,39 @@
+Subject: drbd-tools: only rmmod if DRBD is a module
+
+Account for the case if the DRBD drive is built into
+the kernel. Otherwise, errors, like the following,
+will occur:
+
+root@localhost:~# /etc/init.d/drbd stop
+ Stopping all DRBD resources: ERROR: Module drbd does not exist in
+ /proc/modules
+
+Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
+Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
+
+[ refresh to 8.4.4: squash Aws' and Jason's patches ]
+Signed-off-by: Michel Thebeau <michel.thebeau@windriver.com>
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ scripts/drbd | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/scripts/drbd b/scripts/drbd
+index 20bf628..de589dc 100755
+--- a/scripts/drbd
++++ b/scripts/drbd
+@@ -241,7 +241,9 @@ case "$1" in
+ if [ -d /sys/module/drbd/holders ]; then
+ (cd /sys/module/drbd/holders; for tr in *; do [ -d ${tr} ] && ${RMMOD} ${tr}; done)
+ fi
+- $RMMOD drbd && break
++ if [ ! -z "$(cat /proc/modules | grep -w drbd)" ]; then
++ $RMMOD drbd && break
++ fi
+ fi
+ done
+ run_hook stop
+--
+1.9.1
+
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb b/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
index 5f6c43f7ea..5979fbb587 100644
--- a/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
+++ b/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
SRC_URI = "http://oss.linbit.com/drbd/${BP}.tar.gz \
file://0001-Makefile.in-fix-permission-bits-for-drbd.service.patch \
+ file://0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch \
"
SRC_URI[md5sum] = "76ed6d3190cd77b00890f3365353124b"
SRC_URI[sha256sum] = "297b77c9b3f88de2e7dae459234f2753ea4fc2805282b2d276e35cf51e292913"