aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-10-18 22:38:26 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-11-14 10:07:27 -0500
commitaebf681a9e7cf6b6018892e05f53a6c5806e6e2f (patch)
tree843115af791eeef86b457363fbe95141ac00f9f2 /meta-networking/recipes-support
parentc8f78ecb9b8a39a955631ca1a415d94da588bc26 (diff)
downloadmeta-openembedded-contrib-aebf681a9e7cf6b6018892e05f53a6c5806e6e2f.tar.gz
lowpan-tools: Fix errors found with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch34
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb6
2 files changed, 39 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch
new file mode 100644
index 0000000000..8e906f7ce0
--- /dev/null
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch
@@ -0,0 +1,34 @@
+From 5f9e80acb0a1ac399839bf160e43f6120c4b5128 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 18 Oct 2016 23:49:09 +0000
+Subject: [PATCH] Fix build errors with clang
+
+| ../../../../../../../workspace/sources/lowpan-tools/src/coordinator.c:313:50: error: format specifies type 'unsigned char' but the argument has type 'int' [-Werror,-Wformat]
+| fprintf(stderr, "Opt: %c (%hhx)\n", (char)opt, opt);
+| ~~~~ ^~~
+| %x
+| 1 error generated.
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/coordinator.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/coordinator.c b/src/coordinator.c
+index c139aae..f0de6d2 100644
+--- a/src/coordinator.c
++++ b/src/coordinator.c
+@@ -310,7 +310,7 @@ int main(int argc, char **argv)
+ #else
+ opt = getopt(argc, argv, "l:f:d:m:n:i:s:p:c:hv");
+ #endif
+- fprintf(stderr, "Opt: %c (%hhx)\n", opt, opt);
++ fprintf(stderr, "Opt: %c (%hhx)\n", opt, (unsigned char)opt);
+ if (opt == -1)
+ break;
+
+--
+1.9.1
+
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
index 76a4edf68f..8c7dbc09af 100644
--- a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -9,7 +9,9 @@ DEPENDS = "flex-native bison-native libnl python"
PV = "0.3.1+git${SRCPV}"
SRC_URI = "git://git.code.sf.net/p/linux-zigbee/linux-zigbee \
- file://no-help2man.patch"
+ file://no-help2man.patch \
+ file://0001-Fix-build-errors-with-clang.patch \
+ "
SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733"
S = "${WORKDIR}/git"
@@ -18,6 +20,8 @@ inherit autotools python-dir pkgconfig
CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools"
+CFLAGS += "-Wno-initializer-overrides"
+
do_install_append() {
rmdir ${D}${localstatedir}/run
}