aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2016-11-01 17:23:05 +0800
committerArmin Kuster <akuster808@gmail.com>2016-11-29 08:22:21 -0800
commitb840fceeb6fd225edbc5de937159df07211740db (patch)
tree785bacf02340fd0453e34027636e67a16a16a1d5 /meta-networking/recipes-support
parent705a4c1e2fd3b752bc05b50c50ffc7ad649cbf1c (diff)
downloadmeta-openembedded-contrib-b840fceeb6fd225edbc5de937159df07211740db.tar.gz
tunctl: fix QA warning for GNU_HASH
Add LDFLAGS variable to Makefile so that extra linker flags can be sent via this variable. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit 294d7126ff5a6a079595a56513b789619de5944d) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/tunctl/tunctl.inc4
-rw-r--r--meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch19
2 files changed, 22 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/tunctl/tunctl.inc b/meta-networking/recipes-support/tunctl/tunctl.inc
index e95cfa523d..1c11823dd5 100644
--- a/meta-networking/recipes-support/tunctl/tunctl.inc
+++ b/meta-networking/recipes-support/tunctl/tunctl.inc
@@ -3,7 +3,9 @@ SECTION = "net"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://tunctl.c;beginline=1;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
-SRC_URI = "${SOURCEFORGE_MIRROR}/tunctl/tunctl-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/tunctl/tunctl-${PV}.tar.gz \
+ file://makefile-add-ldflags.patch \
+ "
do_compile() {
oe_runmake tunctl
diff --git a/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch b/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch
new file mode 100644
index 0000000000..c96f538d2d
--- /dev/null
+++ b/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch
@@ -0,0 +1,19 @@
+Add LDFLAGS variable to Makefile, make sure the extra linker flags can be passed.
+
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+diff --git a/Makefile b/Makefile
+index a0aa7f6..d6ce2c7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -14,7 +14,7 @@ MAN_DIR ?= /usr/share/man/man$(MANS)
+ all : $(BIN) $(MAN)
+
+ $(BIN) : $(BIN).c
+- $(CC) $(CFLAGS) -o $(BIN) $(BIN).c
++ $(CC) $(CFLAGS) ${LDFLAGS} -o $(BIN) $(BIN).c
+
+ $(MAN) : $(PACKAGE).sgml
+ docbook2man $(PACKAGE).sgml