aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-03-29 14:28:51 +0200
committerKhem Raj <raj.khem@gmail.com>2022-03-29 08:33:41 -0700
commit481e4555642edb382cf78779f91ec8299d3f474b (patch)
tree5d4b823b77fbd4b147efee7c3a927930e7953a33 /meta-networking
parent33db887513658ad41514bdbff58d0095c4507445 (diff)
downloadmeta-openembedded-contrib-481e4555642edb382cf78779f91ec8299d3f474b.tar.gz
blueman: update; add missing RDEPENDS
- update to v2.2.4 - switch to meson buildsystem - add missing RDEPENDS Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch29
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb (renamed from meta-networking/recipes-connectivity/blueman/blueman_2.2.3.bb)30
2 files changed, 26 insertions, 33 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch b/meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch
index 269174b2f6..913566dce9 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch
+++ b/meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch
@@ -1,31 +1,24 @@
-From 77db892cdee265e971270c06ca1ffbaeea6449a3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
-Date: Tue, 26 Jun 2018 00:27:40 +0200
Subject: [PATCH] Search for cython3
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
-Upstream-Status: Pending
+Upstream-Status: Inappropriate
-Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+Signed-off-by: Markus Volk <f_l_k@gmx.net>
---
- configure.ac | 2 +-
+ meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/configure.ac b/configure.ac
-index 727089d1..6b565cdc 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -58,7 +58,7 @@ AC_SUBST([PYGOBJECT_LIBS])
+--- a/module/meson.build 2022-02-10 08:49:35.000000000 +0100
++++ b/module/meson.build 2022-03-29 12:58:03.456193737 +0200
+@@ -1,4 +1,4 @@
+-cython = find_program('cython', required: true)
++cython = find_program('cython3', required: true)
- AC_ARG_VAR([CYTHONEXEC], [Cython compiler])
- if test "x$CYTHONEXEC" = "x"; then
-- AC_PATH_PROG([CYTHONEXEC],[cython])
-+ AC_PATH_PROG([CYTHONEXEC],[cython3])
- fi
- AC_SUBST([CYTHONEXEC])
- AC_MSG_CHECKING([for cython executable])
+ blueman_c = custom_target(
+ 'blueman_c',
+
--
2.14.3
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.2.3.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb
index a16bcf77a5..ea06ee67f7 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman_2.2.3.bb
+++ b/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb
@@ -2,22 +2,18 @@ DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
+DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native"
-inherit autotools gettext systemd gsettings pkgconfig python3native gtk-icon-cache
+inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache
SRC_URI = " \
https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
file://0001-Search-for-cython3.patch \
file://0002-fix-fail-to-enable-bluetooth.patch \
"
-SRC_URI[sha256sum] = "6edd791da6afd8f610ffb08d5138cfcf50e6257ad30efad686287f3a2be106e9"
+SRC_URI[sha256sum] = "55d639feeda0b43b18a659e65985213a54b47dcb1348f3b4effb5238db242602"
-EXTRA_OECONF = " \
- --disable-appindicator \
- --disable-runtime-deps-check \
- --disable-schemas-compile \
-"
+EXTRA_OEMESON = "-Druntime_deps_check=false -Dappindicator=false"
SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service"
SYSTEMD_AUTO_ENABLE:${PN} = "disable"
@@ -26,22 +22,25 @@ RRECOMENDS_${PN} += "adwaita-icon-theme"
RDEPENDS:${PN} += " \
python3-core \
python3-dbus \
+ python3-pygobject \
+ python3-terminal \
packagegroup-tools-bluetooth \
"
-PACKAGECONFIG ??= "thunar"
-PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto"
+PACKAGECONFIG ??= " \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'polkit pulseaudio ', d)} \
+ thunar \
+"
+PACKAGECONFIG[thunar] = "-Dthunar-sendto=true,-Dthunar-sendto=false"
+PACKAGECONFIG[pulseaudio] = "-Dpulseaudio=true,-Dpulseaudio=false"
+PACKAGECONFIG[polkit] = "-Dpolicykit=true,-Dpolicykit=false"
FILES:${PN} += " \
- ${datadir}/dbus-1 \
- ${datadir}/Thunar \
+ ${datadir} \
${systemd_user_unitdir} \
- ${exec_prefix}${systemd_system_unitdir} \
${PYTHON_SITEPACKAGES_DIR} \
"
-FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"
-
# In code, path to python is a variable that is replaced with path to native version of it
# during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3.
# Replace it with #!/usr/bin/env python3
@@ -55,3 +54,4 @@ do_install:append() {
${D}${bindir}/blueman-services \
${D}${bindir}/blueman-tray
}
+