aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2022-04-24 02:27:56 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-25 10:44:13 -0700
commit5f6156c0ef842bd39e9eb1f7ce02eb7c7c961d3a (patch)
tree682e38c4c0f53174f16b589f581c2468dc3a6409 /meta-networking
parenta47c833126334404fcad459cc683e304fee54595 (diff)
downloadmeta-openembedded-contrib-5f6156c0ef842bd39e9eb1f7ce02eb7c7c961d3a.tar.gz
libldb: Fix installed-vs-shipped and rebuild error
Fixed when multilib is disabled on intel-x86-64: MULITLIBS = "" $ bitbake sssd ERROR: sssd-2.5.2-r0 do_package: QA Issue: sssd: Files/directories were installed but not shipped in any package: /usr/lib/ldb /usr/lib64/ldb/modules/ldb/memberof.so Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. sssd: 2 installed and not shipped files. [installed-vs-shipped] And also remove bin/ got get a clean rebuild, otherwise, the rebuild result may be incorrect. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/libldb/libldb_2.3.3.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libldb/libldb_2.3.3.bb b/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
index c46a9784e3..6dd3ec3a9a 100644
--- a/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
+++ b/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
@@ -68,3 +68,14 @@ FILES:pyldb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \
FILES:pyldb-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug \
${libdir}/.debug/libpyldb-util.*.so.*"
FILES:pyldb-dev = "${libdir}/libpyldb-util.*.so"
+
+# Prevent third_party/waf/waflib/Configure.py checking host's path which is
+# incorrect for cross building.
+export PREFIX = "/"
+export LIBDIR = "${libdir}"
+export BINDIR = "${bindir}"
+
+do_configure:prepend() {
+ # For a clean rebuild
+ rm -fr bin/
+}