aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2022-04-28 10:44:06 -0700
committerArmin Kuster <akuster808@gmail.com>2022-04-29 07:01:33 -0700
commit7e836a08b7c8d083dc9050eff3aac2db1ac6a665 (patch)
tree5b84bf91d67195c8210b269af1c2f0a7766446d6 /meta-networking
parent471a4229ece2b59c5786f8fc4c47e667e9bc97fe (diff)
downloadmeta-openembedded-contrib-7e836a08b7c8d083dc9050eff3aac2db1ac6a665.tar.gz
netplan: move from meta-networking to meta-oe
add to the dynamic meta-pthon lot Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch26
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch44
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch30
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.104.bb68
4 files changed, 0 insertions, 168 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
deleted file mode 100644
index 613858f6fd..0000000000
--- a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From a06c77557ed951249d5b344441ad6ec57410e63f Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex@linutronix.de>
-Date: Sun, 3 Oct 2021 21:52:16 +0200
-Subject: [PATCH] Makefile: do not use -Werror
-
-Upstream-Status: Inappropriate [oe-core specific]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- Makefile | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 0368e41..53d6a9d 100644
---- a/Makefile
-+++ b/Makefile
-@@ -8,7 +8,6 @@ BUILDFLAGS = \
- -DSBINDIR=\"$(SBINDIR)\" \
- -I${CURDIR}/include \
- -Wall \
-- -Werror \
- $(NULL)
-
- SRCS = \
---
-2.25.1
-
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
deleted file mode 100644
index 2149ee30cd..0000000000
--- a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 2e84550b47b475d830622f41576992a1d45d6af0 Mon Sep 17 00:00:00 2001
-From: Zhao Yi <38274519+yizhao1@users.noreply.github.com>
-Date: Tue, 15 Mar 2022 19:28:26 +0800
-Subject: [PATCH] Makefile: fix parallel build failure (#267)
-
-* Makefile: fix parallel build failure
-
-Add src/_features.h as dependency for dbus.o to fix the parallel build
-failure:
-src/dbus.c:17:10: fatal error: _features.h: No such file or directory
-
-Upstream-Status: Backport
-[https://github.com/canonical/netplan/commit/2e84550b47b475d830622f41576992a1d45d6af0]
-
-Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 0368e41..8ac7432 100644
---- a/Makefile
-+++ b/Makefile
-@@ -52,7 +52,7 @@ NOSETESTS3 ?= $(shell command -v nosetests-3 || command -v nosetests3 || echo tr
-
- default: netplan/_features.py generate netplan-dbus dbus/io.netplan.Netplan.service doc/netplan.html doc/netplan.5 doc/netplan-generate.8 doc/netplan-apply.8 doc/netplan-try.8 doc/netplan-dbus.8 doc/netplan-get.8 doc/netplan-set.8
-
--%.o: src/%.c
-+%.o: src/%.c src/_features.h
- $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -c $^ `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
-
- libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
-@@ -62,7 +62,7 @@ libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
- generate: libnetplan.so.$(NETPLAN_SOVER) generate.o
- $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$^) -L. -lnetplan `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
-
--netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) src/_features.h dbus.o
-+netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) dbus.o
- $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$(patsubst %.h,,$^)) -L. -lnetplan `pkg-config --cflags --libs libsystemd glib-2.0 gio-2.0 yaml-0.1 uuid`
-
- src/_features.h: src/[^_]*.[hc]
---
-2.25.1
-
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
deleted file mode 100644
index 8779c251a5..0000000000
--- a/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From e0df1f07d1707d5daf0358cc60b30f06121f7e60 Mon Sep 17 00:00:00 2001
-From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
-Date: Fri, 25 Dec 2020 11:41:43 +0900
-Subject: [PATCH] don't fail if GLOB_BRACE is not defined
-
-Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
----
- src/util.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/src/util.c b/src/util.c
-index 841ec12..59595da 100644
---- a/src/util.c
-+++ b/src/util.c
-@@ -32,6 +32,12 @@
- #include "names.h"
- #include "yaml-helpers.h"
-
-+/* Don't fail if the standard library
-+ * doesn't provide brace expansion */
-+#ifndef GLOB_BRACE
-+#define GLOB_BRACE 0
-+#endif
-+
- NETPLAN_ABI GHashTable*
- wifi_frequency_24;
-
---
-2.25.1
-
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
deleted file mode 100644
index ea944fa9db..0000000000
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
+++ /dev/null
@@ -1,68 +0,0 @@
-SUMMARY = "The network configuration abstraction renderer"
-DESCRIPTION = "Netplan is a utility for easily configuring networking on a \
-linux system. You simply create a YAML description of the required network \
-interfaces and what each should be configured to do. From this description \
-Netplan will generate all the necessary configuration for your chosen renderer \
-tool."
-HOMEPAGE = "https://netplan.io"
-SECTION = "net/misc"
-
-LICENSE = "GPL-3.0-only"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-
-S = "${WORKDIR}/git"
-SRCREV = "3e522b7255310bdecca6c781137741dfc4abc021"
-PV = "0.104"
-
-SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \
- file://0001-Makefile-do-not-use-Werror.patch \
- file://0001-Makefile-fix-parallel-build-failure.patch \
- "
-
-SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"
-
-DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
-
-PACKAGECONFIG ?= ""
-
-PACKAGECONFIG[tests] = ",,,python3-nose python3-coverage python3-netifaces python3-pycodestyle python3-pyflakes python3-pyyaml"
-
-RDEPENDS:${PN} = "python3 python3-core python3-netifaces python3-pyyaml util-linux-libuuid libnetplan"
-
-inherit pkgconfig systemd
-
-TARGET_CC_ARCH += "${LDFLAGS}"
-
-EXTRA_OEMAKE = "generate netplan/_features.py"
-EXTRA_OEMAKE =+ "${@bb.utils.contains('DISTRO_FEATURES','systemd','netplan-dbus dbus/io.netplan.Netplan.service','',d)}"
-
-do_install() {
- install -d ${D}${sbindir} ${D}${libdir} ${D}${base_libdir}/netplan ${D}${datadir}/netplan/netplan/cli/commands ${D}${sysconfdir}/netplan
- install -m 755 ${S}/generate ${D}${base_libdir}/netplan/
- install -m 644 ${S}/netplan/*.py ${D}${datadir}/netplan/netplan
- install -m 644 ${S}/netplan/cli/*.py ${D}${datadir}/netplan/netplan/cli
- install -m 644 ${S}/netplan/cli/commands/*.py ${D}${datadir}/netplan/netplan/cli/commands
- install -m 755 ${S}/src/netplan.script ${D}${datadir}/netplan/
- ln -srf ${D}${datadir}/netplan/netplan.script ${D}${sbindir}/netplan
- sed -i -e "s#/lib/netplan/generate#${base_libdir}/netplan/generate#" ${D}${datadir}/netplan/netplan/cli/utils.py
-
- install -d ${D}/${systemd_unitdir}/system ${D}${systemd_unitdir}/system-generators
- ln -srf ${D}/${base_libdir}/netplan/generate ${D}${systemd_unitdir}/system-generators
-
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${datadir}/dbus-1/system.d ${D}${datadir}/dbus-1/system-services
- install -m 755 ${S}/netplan-dbus ${D}${base_libdir}/netplan
- install -m 644 ${S}/dbus/io.netplan.Netplan.conf ${D}${datadir}/dbus-1/system.d
- install -m 644 ${S}/dbus/io.netplan.Netplan.service ${D}${datadir}/dbus-1/system-services
- sed -i -e "s#^Exec=/lib/#Exec=${base_libdir}/#" ${D}${datadir}/dbus-1/system-services/io.netplan.Netplan.service
- fi
-
- install -m 755 ${S}/libnetplan.so.0.0 ${D}${libdir}
- ln -rfs ${D}${libdir}/libnetplan.so.0.0 ${D}${libdir}/libnetplan.so
-}
-
-PACKAGES += "${PN}-dbus libnetplan"
-
-FILES:libnetplan = "${libdir}/libnetplan.so.0.0"
-FILES:${PN} = "${sbindir} ${base_libdir}/netplan/generate ${datadir}/netplan ${sysconfdir}/netplan ${systemd_unitdir}"
-FILES:${PN}-dbus = "${base_libdir}/netplan/netplan-dbus ${datadir}/dbus-1"