aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-05-07 07:13:20 -0700
committerArmin Kuster <akuster808@gmail.com>2016-05-13 23:04:36 -0700
commit761a6866c7b1ac8eeabb54c8869f46d344dc742e (patch)
tree28802b91143c1e151f271bb983be637640fb7ae7 /meta-networking
parent88a4748ea10124c37fd3245eadbf02b88561f361 (diff)
downloadmeta-openembedded-contrib-761a6866c7b1ac8eeabb54c8869f46d344dc742e.tar.gz
wireshark: Fix new QA Error
NOTE: Resolving any missing task queue dependencies ERROR: Nothing PROVIDES 'libepoxy' (but /oss/maint/mylayers/openembedded-core/meta/recipes-gnome/gtk+/gtk+3_3.18.8.bb DEPENDS on or otherwise requires it) ERROR: libepoxy was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES) add DISTRO_FEATURES check for opengl to enable gtk3 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.0.2.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.0.2.bb b/meta-networking/recipes-support/wireshark/wireshark_2.0.2.bb
index b140099b80..f3061727f3 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_2.0.2.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_2.0.2.bb
@@ -18,11 +18,12 @@ inherit autotools pkgconfig
ARM_INSTRUCTION_SET = "arm"
# Works with either gtk+ or gtk3.
-WHICH_GTK = "gtk3"
+WHICH_GTK = "gtk+"
PACKAGECONFIG ?= "libpcap gnutls libnl libcap"
-PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
+PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
+#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"