aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorPaul Gortmaker <paul.gortmaker@windriver.com>2017-02-19 20:15:49 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2017-03-23 08:26:58 -0400
commit1a63d1dcf383b338bbe11a79c3c634abacd43977 (patch)
treeaa765a519d333862dbf533e9d482d1bcf982f9a1 /meta-networking
parentd63e5687c7bf6b054c6ed2fc4790e4970b023219 (diff)
downloadmeta-openembedded-contrib-1a63d1dcf383b338bbe11a79c3c634abacd43977.tar.gz
netcat-openbsd: fix implicit dependency on pkg-config
In the report at http://errors.yoctoproject.org/Errors/Details/130673/ we see the following: i586-oe-linux-gcc -m32 -march=i586 <snip> netcat.o atomicio.o socks.o `pkg-config --libs libbsd` -lresolv -o nc /bin/sh: 1: pkg-config: not found What follows is a bunch of link errors for BSD library functions, as the backtick didn't return anything but an empty string and hence no BSD library was involved in the link. I was able to reproduce this by temporarily removing my host version of pkg-config, and then validated that this fix solves it while still having the host binary removed. So it should fix the reported issue. I also confirmed pkg-config was in the sysroot after the change. Cc: Khem Raj <raj.khem@gmail.com> Cc: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
index bb21e0cfee..e0a0328ecc 100644
--- a/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
@@ -14,6 +14,8 @@ SRC_URI[netcat.sha256sum] = "40653fe66c1516876b61b07e093d826e2a5463c5d994f1b7e6c
SRC_URI[netcat-patch.md5sum] = "e914f8eb7eda5c75c679dd77787ac76b"
SRC_URI[netcat-patch.sha256sum] = "eee759327ffea293e81d0dde67921b7fcfcad279ffd7a2c9d037bbc8f882b363"
+inherit pkgconfig
+
S = "${WORKDIR}/${BPN}-${PV}"
EXTRA_OEMAKE += "'LDFLAGS=${LDFLAGS}'"
@@ -42,5 +44,3 @@ do_install() {
install -m 755 ${S}/nc ${D}${bindir}/nc.${BPN}
}
ALTERNATIVE_PRIORITY = "60"
-
-PNBLACKLIST[netcat-openbsd] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130673/"