aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2016-01-14 15:03:35 -0600
committerJoe MacDonald <joe_macdonald@mentor.com>2016-02-29 16:23:34 -0500
commit1dc17cc4ad54d6b8af7639ca9d4abf648a82608b (patch)
tree09a309c92edb062c9bf1208ded270ddb4eb9b929 /meta-networking
parente5ac52b4ad1c5b2a811fb0def618b161b86877b5 (diff)
downloadmeta-openembedded-contrib-1dc17cc4ad54d6b8af7639ca9d4abf648a82608b.tar.gz
lldpd: use bash-completion.bbclass
Use bash-completion.bbclass to package bash completions. Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/lldpd/lldpd_0.9.0.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta-networking/recipes-daemons/lldpd/lldpd_0.9.0.bb b/meta-networking/recipes-daemons/lldpd/lldpd_0.9.0.bb
index 3d971698ec..9d5c8a57b4 100644
--- a/meta-networking/recipes-daemons/lldpd/lldpd_0.9.0.bb
+++ b/meta-networking/recipes-daemons/lldpd/lldpd_0.9.0.bb
@@ -14,7 +14,7 @@ SRC_URI = "\
SRC_URI[md5sum] = "ed0226129b0c90b3a45c273fe1aba8de"
SRC_URI[sha256sum] = "300e4a590f7bf21c79d5ff94c2d6a69d0b2c34dbc21e17281496462a04ca80bc"
-inherit autotools update-rc.d useradd systemd pkgconfig
+inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system -g lldpd --shell /bin/false lldpd"
@@ -55,16 +55,11 @@ do_install_append() {
touch ${D}${sysconfdir}/lldpd.conf
}
-PACKAGES =+ "${PN}-bash-completion ${PN}-zsh-completion"
+PACKAGES =+ "${PN}-zsh-completion"
FILES_${PN} += "${libdir}/sysusers.d"
RDEPENDS_${PN} += "os-release"
-FILES_${PN}-bash-completion += "${sysconfdir}/bash_completion.d/ \
- ${datadir}/bash-completion/ \
- "
-RDEPENDS_${PN}-bash-completion += "bash"
-
FILES_${PN}-zsh-completion += "${datadir}/zsh/"
# FIXME: zsh is broken in meta-oe so this cannot be enabled for now
#RDEPENDS_${PN}-zsh-completion += "zsh"