aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-24 17:06:59 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-09-05 13:34:12 -0400
commit20681efaff1a251e5134ac0310ea17b7fdfed441 (patch)
tree8374248300179e7d8b106778d60232a711bff469 /meta-networking
parent940a621f190b71549968fd8879482c9dc2a924ee (diff)
downloadmeta-openembedded-contrib-20681efaff1a251e5134ac0310ea17b7fdfed441.tar.gz
znc: control ipv6 support based on DISTRO_FEATURES
Add PACKAGECONFIG for ipv6 and control it based on DISTRO_FEATURES. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-irc/znc/znc_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-irc/znc/znc_git.bb b/meta-networking/recipes-irc/znc/znc_git.bb
index 22aecbad2d..f3345a9443 100644
--- a/meta-networking/recipes-irc/znc/znc_git.bb
+++ b/meta-networking/recipes-irc/znc/znc_git.bb
@@ -21,6 +21,9 @@ S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
+
# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
do_configure_prepend() {
automake --add-missing || true