aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2016-01-27 17:36:51 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-02-22 15:51:19 -0500
commitd780562322092894f8f0545ab751cc34133f9b91 (patch)
tree0668391e929cf2c6a819e4119f9db9f0c5a1f137 /meta-networking
parent1ddc9a5e653d0869df5fd9ccf16128cee88008c6 (diff)
downloadmeta-openembedded-contrib-d780562322092894f8f0545ab751cc34133f9b91.tar.gz
netkit-telnet: Add to generate telnetlogin.
* Add oe_runmake line for telnetlogin to make the telnetlogin folder to be built. * Add FILES_${PN} line to let ${libdir}/telnetlogin to be included in netkit-telnet package. * Customize "install -D -m 4750 ${B}/telnetlogin/telnetlogin ${D}/${libdir}/telnetlogin" to let the telnetlogin to be installed under /usr/lib64 on 64bit system. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb b/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb
index 0806518733..9438adc0f2 100644
--- a/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb
+++ b/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb
@@ -25,6 +25,7 @@ do_configure () {
do_compile () {
oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet
oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' LIBS=-lutil SUB=telnetd
+ oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnetlogin
}
do_install () {
@@ -36,6 +37,7 @@ do_install () {
install -d ${D}${mandir}/man8
oe_runmake SUB=telnetd install
rm -rf ${D}${mandir}/man1
+ install -D -m 4750 ${B}/telnetlogin/telnetlogin ${D}/${libdir}/telnetlogin
# fix up hardcoded paths
sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/telnet-xinetd
install -d ${D}/etc/xinetd.d/
@@ -54,3 +56,4 @@ pkg_prerm_${PN} () {
SRC_URI[md5sum] = "d6beabaaf53fe6e382c42ce3faa05a36"
SRC_URI[sha256sum] = "9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00"
+FILES_${PN} += "${sbindir}/in.* ${libdir}/* ${sysconfdir}/xinetd.d/*"