aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2017-08-23 18:08:43 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 14:59:52 +0200
commitb04d96cec172fa09b5cc237f6646e733995ecc15 (patch)
tree447d9f1c7c783ed5197c9b18121cdf3654e29ba6 /meta-networking
parent87377c81cf163ac2bc3940b2d0b130e0c9ebc56a (diff)
downloadmeta-openembedded-contrib-b04d96cec172fa09b5cc237f6646e733995ecc15.tar.gz
openconnect: fix parallel compilation failure
This patch solves the following error which appears now and then because of parallel building. ../git/main.c:78:21: fatal error: version.c: No such file or directory version.c is generated at build time. And it's needed by some objects. So it needs to be generated first to avoid compilation failure. This patch fix the problem by generating version.c first before building others. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/openconnect/openconnect_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb b/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb
index 3a1f0f30f0..4242aa5538 100644
--- a/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb
+++ b/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb
@@ -25,3 +25,7 @@ inherit autotools pkgconfig
EXTRA_OECONF += "--with-vpnc-script=${SYSROOT_DESTDIR}${sysconfdir}/vpnc/vpnc-script \
--disable-static"
+
+do_compile_prepend() {
+ make version.c
+}