aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2016-05-27 17:54:57 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-06-01 19:35:50 -0400
commita6a36710a110d381b798b445b2da9d6c490215f3 (patch)
tree251c02ee761f0dc5ed487ecae2827cb74394f733 /meta-networking
parentd765990dd2fc9324963e9ecb0f93b7e613e874ad (diff)
downloadmeta-openembedded-contrib-a6a36710a110d381b798b445b2da9d6c490215f3.tar.gz
cifs-utils: make samba conditional dependency
Add PACKAGECONFIG for cifsacl and update PACKAGECONFIG for cifsidmap to make samba a conditional dependency. It is nice to be able to get mount.cifs without needing to build samba. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_git.bb b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
index 87306a6f28..099d885c90 100644
--- a/meta-networking/recipes-support/cifs/cifs-utils_git.bb
+++ b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
@@ -4,7 +4,6 @@ SECTION = "otherosfs"
LICENSE = "GPLv3 & LGPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS = "samba"
PV = "6.4"
SRCREV = "487f46da737291877867cbd3acb40fea087d3863"
@@ -18,7 +17,8 @@ PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
-PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap, keyutils"
+PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samba"
+PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
inherit autotools pkgconfig