aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2019-11-07 21:42:34 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-07 17:43:44 -0800
commitd8ab89a24b9350a045bfe0faa31b9545061ce092 (patch)
tree9889d8dcd26150e58a1375a2e6b7848d53caeb3d /meta-networking
parent1a3ab20ac6b995b95124daf9c5b3a6b77445514b (diff)
downloadmeta-openembedded-contrib-d8ab89a24b9350a045bfe0faa31b9545061ce092.tar.gz
autofs: install sysvinit script manually if systemd is enabled
Update-rc.d complains if no sysvinit script is present. This happens in hybrid systemd/sysvinit builds, because autofs does not install the init script if configured with '--with-systemd'. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb
index 4f61562731..54f0b99915 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb
@@ -79,6 +79,11 @@ do_install_append () {
if [ -d ${D}${localstatedir}/run ]; then
rmdir ${D}${localstatedir}/run
fi
+ # On hybrid systemd/sysvinit builds, we need to install the sysvinit script by hand.
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d -m 755 ${D}${INIT_D_DIR}
+ install -m 755 ${S}/samples/rc.autofs ${D}${INIT_D_DIR}/autofs
+ fi
}
SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"