aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authormike.looijmans@topic.nl <mike.looijmans@topic.nl>2016-01-11 18:53:52 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-01-20 21:41:46 -0500
commit751659c243caae359213ee1cdb242c7eaadda73b (patch)
treee5d892d9e4e95e7e0186f71ac3ca490361241110 /meta-networking
parent37edcea5b7285df33dbaf125f9287c46f89c43bb (diff)
downloadmeta-openembedded-contrib-751659c243caae359213ee1cdb242c7eaadda73b.tar.gz
recipes-connectivity/samba: Only rmdir directories that exist
Depending on PACKAGECONFIG selection, the /run/samba directory may not have been created. Make the do_install_append handle both situations by checking whether these directories exist before attempting to remove them. This fixes do_install failing with an error like this: rmdir: failed to remove '/.../samba/4.1.12-r0/image/run/samba': No such file or directory Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.1.12.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
index 3d677bec15..42315138ea 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
@@ -111,8 +111,12 @@ EXTRA_OECONF += "--enable-fhs \
LDFLAGS += "-Wl,-z,relro,-z,now"
do_install_append() {
- rmdir --ignore-fail-on-non-empty "${D}/run/samba"
- rmdir --ignore-fail-on-non-empty "${D}/run"
+ if [ -d "${D}/run" ]; then
+ if [ -d "${D}/run/samba" ]; then
+ rmdir --ignore-fail-on-non-empty "${D}/run/samba"
+ fi
+ rmdir --ignore-fail-on-non-empty "${D}/run"
+ fi
if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system