aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-05-29 15:47:28 +0800
committerKhem Raj <raj.khem@gmail.com>2019-05-29 02:21:42 -0700
commit8e641e28f630dac61a03373ad70c72a2370ad11e (patch)
tree8a9b5aed9be2df30aa813c2d4815fe67be863b19 /meta-networking
parent1ac44de1358807b9fa848d394e093713f929f686 (diff)
downloadmeta-openembedded-contrib-8e641e28f630dac61a03373ad70c72a2370ad11e.tar.gz
samba/libldb: add rconflicts
samba have bundled libldb, so when both samba and libldb, or both pyldb \ and samba-python is installed, below error will appear: file /usr/bin/ldbadd conflicts between attempted installs of samba-4.8.11-r0.i586 and libldb-1.4.1-r0.i586 file /usr/bin/ldbdel conflicts between attempted installs of samba-4.8.11-r0.i586 and libldb-1.4.1-r0.i586 ... file /usr/lib/python2.7/site-packages/ldb.so conflicts between attempted installs of libpyldb-util1-1.4.1-r0.i586 and samba-python-4.8.11-r0.i586 so add rconflicts for both packages Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.8.11.bb3
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.4.1.bb2
2 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.8.11.bb b/meta-networking/recipes-connectivity/samba/samba_4.8.11.bb
index 8c08d1ed3b..8139ed43cb 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.8.11.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.8.11.bb
@@ -41,6 +41,9 @@ RDEPENDS_${PN}_remove = "perl"
DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libbsd libaio libpam"
+RCONFLICTS_${PN} = "libldb"
+RCONFLICTS_${PN}-python = "pyldb"
+
inherit distro_features_check
REQUIRED_DISTRO_FEATURES = "pam"
diff --git a/meta-networking/recipes-support/libldb/libldb_1.4.1.bb b/meta-networking/recipes-support/libldb/libldb_1.4.1.bb
index 3c7e5455e9..f3608c6abc 100644
--- a/meta-networking/recipes-support/libldb/libldb_1.4.1.bb
+++ b/meta-networking/recipes-support/libldb/libldb_1.4.1.bb
@@ -5,6 +5,8 @@ LICENSE = "LGPL-3.0+ & LGPL-2.1+ & GPL-3.0+"
DEPENDS += "libtdb libtalloc libtevent popt"
RDEPENDS_pyldb += "python samba"
+RCONFLICTS_${PN} = "samba"
+RCONFLICTS_pyldb = "samba-python"
SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \
file://do-not-import-target-module-while-cross-compile.patch \