aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2020-08-03 14:36:50 +0800
committerArmin Kuster <akuster808@gmail.com>2020-08-23 11:12:08 -0700
commit57b629543eb22242180c67f48f653b5b0abbd717 (patch)
tree978b33ca163514510b34769f500cd05da25152fa /meta-networking
parent060d218f82af9070a8e79cefe1093f9b0e6bd7b8 (diff)
downloadmeta-openembedded-contrib-57b629543eb22242180c67f48f653b5b0abbd717.tar.gz
rdist: fix parallel build
It fails to compile rdist occasionally when system load of build server is high: | In file included from common.c:57: | ../include/defs.h:49:10: fatal error: y.tab.h: No such file or directory | 49 | #include "y.tab.h" | | ^~~~~~~~~ | compilation terminated. Make $(COMMONOBJS) which include common.o to depends on related header files and y.tab.h to fix the parallel build failure. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 1bb990c6ca1b149c19404fbe006fb6b372af8c4c) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/rdist/rdist-6.1.5/rdist-6.1.5-fix-parallel-build.patch31
-rw-r--r--meta-networking/recipes-connectivity/rdist/rdist_6.1.5.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/rdist/rdist-6.1.5/rdist-6.1.5-fix-parallel-build.patch b/meta-networking/recipes-connectivity/rdist/rdist-6.1.5/rdist-6.1.5-fix-parallel-build.patch
new file mode 100644
index 0000000000..f35e96a34f
--- /dev/null
+++ b/meta-networking/recipes-connectivity/rdist/rdist-6.1.5/rdist-6.1.5-fix-parallel-build.patch
@@ -0,0 +1,31 @@
+It fails to produce common.o when system load is high:
+
+| In file included from common.c:57:
+| ../include/defs.h:49:10: fatal error: y.tab.h: No such file or directory
+| 49 | #include "y.tab.h"
+| | ^~~~~~~~~
+| compilation terminated.
+
+Make $(COMMONOBJS) which include common.o to depends on related header files
+and y.tab.h to fix the parallel build failure.
+
+Upstream-Status: Inappropriate [no upstream]
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+ src/Makefile.real | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.real b/src/Makefile.real
+index e0f0dfc..53d4944 100644
+--- a/src/Makefile.real
++++ b/src/Makefile.real
+@@ -41,7 +41,7 @@ $(SERVER_BIN): $(SERVEROBJS) $(COMMONOBJS) $(MISSINGOBJS)
+ $(CLIENT_BIN): $(CLIENTOBJS) $(COMMONOBJS) $(MISSINGOBJS)
+ $(CC) -o $@ $(CLIENTOBJS) $(COMMONOBJS) $(MISSINGOBJS) $(LIBS) $(LDFLAGS)
+
+-$(CLIENTOBJS) $(SERVEROBJS): $(HFILES) y.tab.h
++$(COMMONOBJS) $(CLIENTOBJS) $(SERVEROBJS): $(HFILES) y.tab.h
+
+ y.tab.h: gram.c
+
diff --git a/meta-networking/recipes-connectivity/rdist/rdist_6.1.5.bb b/meta-networking/recipes-connectivity/rdist/rdist_6.1.5.bb
index 3a27c2c5b3..37b3eebe4b 100644
--- a/meta-networking/recipes-connectivity/rdist/rdist_6.1.5.bb
+++ b/meta-networking/recipes-connectivity/rdist/rdist_6.1.5.bb
@@ -28,6 +28,7 @@ SRC_URI += "file://rdist-6.1.5-linux.patch \
file://rdist-6.1.5-fix-msgsndnotify-loop.patch \
file://rdist-6.1.5-bb-build.patch \
file://rdist-6.1.5-makefile-add-ldflags.patch \
+ file://rdist-6.1.5-fix-parallel-build.patch \
"
UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/rdist/files/rdist/"