aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-11-17 13:37:37 +0800
committerArmin Kuster <akuster808@gmail.com>2017-01-29 19:15:41 -0500
commitde930625274321de7379850aaabf5fbb5603d4a3 (patch)
tree7b2c0a899238f9f0be0bcd25f482cb5f5c624e1e /meta-networking
parent4758c07d5e3298e2f231c05bdb3048aeae506b04 (diff)
downloadmeta-openembedded-contrib-de930625274321de7379850aaabf5fbb5603d4a3.tar.gz
curlpp: fix qa issue of do_configure
curlpp is configured with boost by default. And it searches boost directory on build machine. If boost is installed on build machine, then causes qa issue: | ERROR: curlpp-0.7.3-r0 do_configure: This autoconf log indicates | errors, it looked at host include and/or library paths while | determining system capabilities. Pass the boost directory in ${STAGING_DIR_HOST} to configure script to disable search on build machine to fix the issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
index 1848aa6dbb..c3a242a316 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
@@ -16,6 +16,7 @@ SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a
inherit autotools-brokensep pkgconfig binconfig
+EXTRA_OECONF = "--with-boost=${STAGING_DIR_HOST}${prefix}"
# Upstream is currently working on porting the code to use std::unique_ptr instead of the
# deprecated auto_ptr. For now, ignore the issue.
CXXFLAGS += "-Wno-error=deprecated-declarations"