aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-03 20:00:22 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-04 07:08:13 -0700
commita854c2cb774077e82663b88d5c4746d5e409f83c (patch)
tree33d2c1a059364a83db349ec519bc036b3a3b367e /meta-networking
parent693ec65bf279c2fa1af9f12a019c58c1a5c23d17 (diff)
downloadmeta-openembedded-contrib-a854c2cb774077e82663b88d5c4746d5e409f83c.tar.gz
mbedtls: Add packageconfig for warning-as-errors
Disable the options by default, as we use different compilers there are more warnings to handle then upstream Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb
index 8c2457ce06..3c7df44513 100644
--- a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb
@@ -32,6 +32,7 @@ inherit cmake
PACKAGECONFIG ??= "shared-libs programs"
PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF"
PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF"
+PACKAGECONFIG[werror] = "-DMBEDTLS_FATAL_WARNINGS=ON,-DMBEDTLS_FATAL_WARNINGS=OFF"
EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}"