aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 17:22:38 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-24 15:31:51 +0200
commit26279f3350204d7ca820383c56351d52f81adf61 (patch)
treee748d54ab53c6e92269f29a952a2f64f2887d1bd /meta-networking
parentf2ec214f097acd84ff044c26a57789b153cee219 (diff)
downloadmeta-openembedded-contrib-26279f3350204d7ca820383c56351d52f81adf61.tar.gz
snort: add openssl PACKAGECONFIG
* otherwise the result isn't deterministic WARN: packages/armv5te-oe-linux-gnueabi/snort/snort/latest lost dependency on libcrypto * enable it by default, disabling currently doesn't work, because there are --with flags for openssl, but then configure.in still checks for sha.h header with AC_CHECK_HEADERS([openssl/sha.h],, SHA_H="no") and autodetects it, I'll leave patching configure to someone who is actually using snort (this issue was reported many times and nobody seems to care). Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb
index ecbbf44cb9..9c55e9c65f 100644
--- a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb
+++ b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb
@@ -32,6 +32,12 @@ EXTRA_OECONF = " \
--with-dnet-libraries=${STAGING_LIBDIR} \
"
+# if you want to disable it, you need to patch configure.in first
+# AC_CHECK_HEADERS([openssl/sha.h],, SHA_H="no")
+# is called even with --without-openssl-includes
+PACKAGECONFIG ?= "openssl"
+PACKAGECONFIG[openssl] = "--with-openssl-includes=${STAGING_INCDIR} --with-openssl-libraries=${STAGING_LIBDIR}, --without-openssl-includes --without-openssl-libraries, openssl,"
+
do_install_append() {
install -d ${D}/${sysconfdir}/snort/rules
install -d ${D}/${sysconfdir}/snort/preproc_rules