aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:49:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:03 +0200
commit5f26b009643d8a1a73aecb3aa0b7c5873943e7a1 (patch)
tree8e0954985027fab490e9cf1549c25455a6da9425 /meta-networking
parent4188d725513fb660348df16c290618dd0e6198ba (diff)
downloadmeta-openembedded-contrib-5f26b009643d8a1a73aecb3aa0b7c5873943e7a1.tar.gz
yp-tools, ypbind-mt: move systemd support from meta-systemd back to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/nis/yp-tools/domainname.service12
-rw-r--r--meta-networking/recipes-support/nis/yp-tools_2.12.bb18
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt/ypbind.service14
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_1.36.bb23
4 files changed, 60 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/nis/yp-tools/domainname.service b/meta-networking/recipes-support/nis/yp-tools/domainname.service
new file mode 100644
index 0000000000..21aa92cb36
--- /dev/null
+++ b/meta-networking/recipes-support/nis/yp-tools/domainname.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=NIS Domainname
+
+[Service]
+Type=oneshot
+EnvironmentFile=/etc/nisdomainname
+ExecStart=/usr/bin/domainname $NISDOMAINNAME
+RemainAfterExit=true
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/meta-networking/recipes-support/nis/yp-tools_2.12.bb b/meta-networking/recipes-support/nis/yp-tools_2.12.bb
index fb7ebc2308..8593c6ba43 100644
--- a/meta-networking/recipes-support/nis/yp-tools_2.12.bb
+++ b/meta-networking/recipes-support/nis/yp-tools_2.12.bb
@@ -1,7 +1,7 @@
# This package builds tools to manage NIS
# The source package is utils/net/NIS/yp-tools
#
-PR = "r0"
+PR = "r3"
DESCRIPTION="\
Network Information Service tools. \
This package contains ypcat, ypmatch, ypset, \
@@ -9,9 +9,23 @@ ypwhich, yppasswd, domainname, nisdomainname \
and ypdomainname."
require nis.inc
-SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2"
+SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \
+ file://domainname.service \
+"
SRC_URI[md5sum] = "ce1e06d86caa285fa8cd76fdf103f51e"
SRC_URI[sha256sum] = "6ae8321666eea7837da343eea90ea30273fb74943ad111d5a4befd2afb252063"
CACHED_CONFIGUREVARS += "ac_cv_prog_STRIP=/bin/true"
+
+inherit systemd
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "domainname.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system
+}
diff --git a/meta-networking/recipes-support/nis/ypbind-mt/ypbind.service b/meta-networking/recipes-support/nis/ypbind-mt/ypbind.service
new file mode 100644
index 0000000000..1f8df42af5
--- /dev/null
+++ b/meta-networking/recipes-support/nis/ypbind-mt/ypbind.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=YP Bind
+Requires=domainname.service
+After=domainname.service network.target
+Before=systemd-user-sessions.service
+
+[Service]
+Type=forking
+PIDFile=/var/run/ypbind.pid
+ExecStart=/usr/sbin/ypbind
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb b/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb
index e2f654c61d..35ef16a89a 100644
--- a/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb
+++ b/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb
@@ -1,7 +1,7 @@
# This package builds the NIS ypbind daemon
# The source package is utils/net/NIS/ypbind-mt
#
-PR = "r0"
+PR = "r3"
DESCRIPTION="\
Multithreaded NIS bind service (ypbind-mt). \
ypbind-mt is a complete new implementation of a NIS \
@@ -16,10 +16,13 @@ HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
require nis.inc
-SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2"
-SRC_URI[md5sum] = "135834db97d78ff6d79fdee2810b4056"
-
LIC_FILES_CHKSUM = "file://COPYING;md5=082c9a0886c7c3db1bc862b5b62ffe08"
+
+SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
+ file://ypbind-yocto.init \
+ file://ypbind.service \
+"
+SRC_URI[md5sum] = "135834db97d78ff6d79fdee2810b4056"
SRC_URI[sha256sum] = "0eff76c1849f4b38ea1a60280d8397c4240369c641fe5402ce57edf1a90958c7"
# ypbind-mt now provides all the functionality of ypbind
@@ -27,7 +30,6 @@ SRC_URI[sha256sum] = "0eff76c1849f4b38ea1a60280d8397c4240369c641fe5402ce57edf1a9
PROVIDES += "ypbind"
CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
-SRC_URI += "file://ypbind-yocto.init"
do_install_append () {
install -d ${D}${sysconfdir}/init.d
@@ -35,5 +37,16 @@ do_install_append () {
install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind
+ # TODO, use update-rc.d
ln -s ../init.d/ypbind ${D}${sysconfdir}/rcS.d/S44ypbind
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
}
+
+inherit systemd
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "ypbind.service"