aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-07-06 11:13:19 +0200
committerKhem Raj <raj.khem@gmail.com>2021-07-08 09:21:40 -0700
commit9569d222eb8ded7a8a5d9ed279b92605c46cd111 (patch)
treee7b4df2f4b25ba961d65edd198f64e1a3692a39f /meta-networking
parent287ffdf1d03731fadd6a90b224d08cf9a3b50de5 (diff)
downloadmeta-openembedded-contrib-9569d222eb8ded7a8a5d9ed279b92605c46cd111.tar.gz
blueman: upgrade 2.1.4 -> 2.2.1
Manually refresh 0002-fix-fail-to-enable-bluetooth.patch - it did not apply 2.2.1 Bugs fixed Hard dependency of DBusService on NetworkManager 2.2 New features Disconnect items in applet menu (plugin) Desktop notifications on connect / disconnect (plugin) Notifications with battery level for connecting devices (applet plugin) Stop discovery and retry connection for broken adapter drivers Auto-connect settings for supported services Changes Drop blueman-report Drop blueman-assistant Raise minimum Python version to 3.6 Raise GTK+ 3 version to 3.22 Raise minimum BlueZ version to 5.48 Allow opening device menus via keyboard (Shift+F10 or menu key) Add Ctrl+Q and Ctrl+W accelerators for closing blueman-manager Allow cancelling device connection attempts Improved passkey handling (fixed padding, highlighting, single notifitication) Hide devices with no name Bugs fixed Fix disconnecting NMDevice Exceptions from asynchronous DBus calls (getting picked up by tools like Apport or ABRT) DiscvManager plugin showed its icon unreliably Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch20
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman_2.2.1.bb (renamed from meta-networking/recipes-connectivity/blueman/blueman_2.1.4.bb)16
2 files changed, 17 insertions, 19 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch b/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch
index 55d1ac94c5..282d821374 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch
+++ b/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch
@@ -22,13 +22,13 @@ Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
blueman/Functions.py | 10 ++++++++++
blueman/plugins/applet/PowerManager.py | 4 ++++
- 2 files changed, 15 insertions(+), 1 deletion(-)
+ 2 files changed, 14 insertions(+)
diff --git a/blueman/Functions.py b/blueman/Functions.py
-index 3b76271..c5eeb27 100644
+index 3917f42..b4d5eae 100644
--- a/blueman/Functions.py
+++ b/blueman/Functions.py
-@@ -86,6 +86,16 @@ def check_bluetooth_status(message, exitfunc):
+@@ -80,6 +80,16 @@ def check_bluetooth_status(message: str, exitfunc: Callable[[], Any]) -> None:
return
applet.SetBluetoothStatus('(b)', True)
@@ -46,27 +46,27 @@ index 3b76271..c5eeb27 100644
print('Failed to enable bluetooth')
exitfunc()
diff --git a/blueman/plugins/applet/PowerManager.py b/blueman/plugins/applet/PowerManager.py
-index 8ec9fc4..29a0fb0 100644
+index c2f7bc3..bf6c99f 100644
--- a/blueman/plugins/applet/PowerManager.py
+++ b/blueman/plugins/applet/PowerManager.py
-@@ -48,6 +48,7 @@ class PowerManager(AppletPlugin):
+@@ -63,6 +63,7 @@ class PowerManager(AppletPlugin, StatusIconProvider):
self._add_dbus_signal("BluetoothStatusChanged", "b")
self._add_dbus_method("SetBluetoothStatus", ("b",), "", self.request_power_state)
self._add_dbus_method("GetBluetoothStatus", (), "b", self.get_bluetooth_status)
+ self._add_dbus_method("GetRequestStatus", (), "b", self.get_request_status)
- def on_unload(self):
+ def on_unload(self) -> None:
self.parent.Plugins.Menu.unregister(self)
-@@ -182,6 +183,9 @@ class PowerManager(AppletPlugin):
- def get_bluetooth_status(self):
+@@ -196,6 +197,9 @@ class PowerManager(AppletPlugin, StatusIconProvider):
+ def get_bluetooth_status(self) -> bool:
return self.current_state
+ def get_request_status(self):
+ return self.request_in_progress
+
- def on_adapter_property_changed(self, _path, key, value):
+ def on_adapter_property_changed(self, _path: str, key: str, value: Any) -> None:
if key == "Powered":
if value and not self.current_state:
--
-2.20.1
+2.31.1
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.1.4.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.2.1.bb
index 29bef230e4..3cb01ff71e 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman_2.1.4.bb
+++ b/meta-networking/recipes-connectivity/blueman/blueman_2.2.1.bb
@@ -4,14 +4,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
-inherit autotools systemd gsettings python3native gtk-icon-cache
+inherit autotools gettext systemd gsettings python3native gtk-icon-cache
SRC_URI = " \
https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
file://0001-Search-for-cython3.patch \
file://0002-fix-fail-to-enable-bluetooth.patch \
"
-SRC_URI[sha256sum] = "1d9c3d39a564d88851aa8de509f16bfa586b0b50f4307dc6c6347ba4833664da"
+SRC_URI[sha256sum] = "fcc10a2259bef2c5ac63f577010d76caed460d68810b7f70fecf056bf10a1a72"
EXTRA_OECONF = " \
--disable-appindicator \
@@ -48,12 +48,10 @@ FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"
do_install_append() {
sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
${D}${prefix}/libexec/blueman-mechanism \
- ${D}${bindir}/blueman-tray \
- ${D}${bindir}/blueman-services \
- ${D}${bindir}/blueman-sendto \
- ${D}${bindir}/blueman-report \
- ${D}${bindir}/blueman-manager \
- ${D}${bindir}/blueman-assistant \
+ ${D}${bindir}/blueman-adapters \
${D}${bindir}/blueman-applet \
- ${D}${bindir}/blueman-adapters
+ ${D}${bindir}/blueman-manager \
+ ${D}${bindir}/blueman-sendto \
+ ${D}${bindir}/blueman-services \
+ ${D}${bindir}/blueman-tray
}