aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2020-05-12 23:52:17 +0300
committerKhem Raj <raj.khem@gmail.com>2020-05-12 14:16:19 -0700
commitffd091179624bbc1a515d28f64201fa4417697d7 (patch)
tree058bd13a6452192e867fe167be84393334f3f2c7 /meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs
parent75b3d7e7bf3ea451c633adc6906c0c1695359fff (diff)
downloadmeta-openembedded-contrib-ffd091179624bbc1a515d28f64201fa4417697d7.tar.gz
mozjs: Remove workaround for gcc < 4.9
Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs')
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0014-fallback-to-2011-C++-standard.patch42
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb1
2 files changed, 0 insertions, 43 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0014-fallback-to-2011-C++-standard.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0014-fallback-to-2011-C++-standard.patch
deleted file mode 100644
index 7a0d286e14..0000000000
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0014-fallback-to-2011-C++-standard.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Option '-std=gnu++14' has been supported from gcc 4.9. But on some build hosts
-such as CentOS 7.6 which only has gcc 4.8.5 and fails to configure:
-
-| checking whether the host C compiler can be used... no
-| ERROR: Only GCC 4.9 or newer is supported (found version 4.8.5).
-
-Fallback to 2011 C++ standard and lower required gcc version to 4.8.0 which is
-the same as in previous version 52.9.1 of mozjs.
-
-Upstream-Status: Inappropriate [Workaround]
-
-Signed-off-by: Kai Kang <kai.kang@windriver.com>
----
-diff --git a/build/moz.configure/toolchain.configure b/build/moz.configure/toolchain.configure
-index 9c772a8..fc640c7 100755
---- a/build/moz.configure/toolchain.configure
-+++ b/build/moz.configure/toolchain.configure
-@@ -502,10 +502,8 @@ def check_compiler(compiler, language, target):
- append_flag('-std=c++14')
- # GCC 4.9 indicates that it implements draft C++14 features
- # instead of the full language.
-- elif info.type == 'gcc' and \
-- info.language_version not in (draft_cxx14_version,
-- cxx14_version):
-- append_flag('-std=gnu++14')
-+ elif info.type == 'gcc' and info.language_version != 201103:
-+ append_flag('-std=gnu++11')
-
- # We force clang-cl to emulate Visual C++ 2017 version 15.4
- if info.type == 'clang-cl' and info.version != '19.11.25547':
-@@ -903,9 +901,9 @@ def compiler(language, host_or_target, c_compiler=None, other_compiler=None,
- # Check the compiler version here instead of in `compiler_version` so
- # that the `checking` message doesn't pretend the compiler can be used
- # to then bail out one line later.
-- if info.type == 'gcc' and info.version < '4.9.0':
-+ if info.type == 'gcc' and info.version < '4.8.0':
- raise FatalCheckError(
-- 'Only GCC 4.9 or newer is supported (found version %s).'
-+ 'Only GCC 4.8 or newer is supported (found version %s).'
- % info.version)
-
- if info.type == 'gcc' and host_or_target.os == 'Android':
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb
index 9466c62aac..f13a184b65 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb
@@ -18,7 +18,6 @@ SRC_URI = " \
file://0011-To-fix-build-error-on-arm32BE.patch \
file://0012-JS_PUBLIC_API.patch \
file://0013-riscv-Disable-atomic-operations.patch \
- file://0014-fallback-to-2011-C++-standard.patch \
"
SRC_URI_append_libc-musl = " \
file://musl/0001-support-musl.patch \