aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-14 18:55:34 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commitd69c259e2daf4a2748cd1bcbd366f651d2eb8564 (patch)
tree6a59a2b7030cf9fd6db200076153df4d5b30003f /meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
parent4fa55201cbbe3dfdaeb0f6a16f000b98906c37ce (diff)
downloadmeta-openembedded-contrib-d69c259e2daf4a2748cd1bcbd366f651d2eb8564.tar.gz
iperf3: Fix missing stdint.h and do not link with -pg
Helps compile with musl Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 85d4fe73352886b4d22a77d8ab5163d267d21fa2) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/iperf3/iperf3_git.bb')
-rw-r--r--meta-oe/recipes-benchmark/iperf3/iperf3_git.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb b/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
index d19aa1ec46..4a01896ca9 100644
--- a/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
+++ b/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
@@ -11,10 +11,11 @@ AUTHOR = "ESNET <info@es.net>, Lawrence Berkeley National Laboratory <websupport
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3434c5a9a53c78c7739f0bc9e5adda"
-SRC_URI = "\
- git://github.com/esnet/iperf.git \
- file://automake-foreign.patch \
-"
+SRC_URI = "git://github.com/esnet/iperf.git \
+ file://automake-foreign.patch \
+ file://0001-include-stdint.h-for-various-std-c99-int-types.patch \
+ file://0002-Remove-pg-from-profile_CFLAGS.patch \
+ "
PV = "3.1.3+gitr${SRCPV}"
SRCREV = "099244ec686b620393e9845478a554b1c7ca5c8b"
@@ -25,4 +26,6 @@ inherit autotools
PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools"
+CFLAGS += "-D_GNU_SOURCE"
+
BBCLASSEXTEND = "native"