aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2014-05-03 15:42:46 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-04 17:14:11 +0200
commit447ef234d4e69f527e4c1c2bea6129b08af30010 (patch)
treef5b7f705f4c80f2158cfd87d6206f204fa41b97e /meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
parent25ca3cf168103ca2591658ffa83946ebd24733b5 (diff)
downloadmeta-openembedded-contrib-447ef234d4e69f527e4c1c2bea6129b08af30010.tar.gz
libhugetlbfs: update srcrev to 2.18 release
* Update recipe: - update SRCREV to latest release, 2.18 - switch back to master branch - increase verbosity (pass V=1 to EXTRA_OEMAKE) to make debugging easier * Drop patches: - fix-lib64-can-not-be-shiped-in-64bit-target.patch replaced by LIBARGS definition. the build system allows to override libdir using LIB32 and LIB64 variables - 0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch replaced by a one-liner to fixup perl module directory hardcoded to perl5 * Refresh skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch - only disable the error to skip the check * Add patches: - 0001-aarch64-fix-cross-compilation.patch - submitted upstream allow to override CC and use it for aarch64 case like the other arch - 0001-aarch64-fix-page-size-not-properly-computed.patch - submitted upstream fix typo on MB variable (MB -> $MB) and add the missing linker variants (aarch64elfb, aarch64linux, aarch64linuxb) - 0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch submitted upstream. replace lib/lib64 hardcoded values by LIBDIR32 and LIBDIR64 variables * Remove patches that aren't applied in the recipe (they're all merged upstream and available in 2.18 release): - libhugetlbfs/files/aarch64-support.patch - aarch64-unit-test-fixes.patch - add-PROT-NONE-to-the-mprotest-test.patch Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 5ee6e8e14e..5645add6b8 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -5,23 +5,23 @@ LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "sysfsutils perl"
RDEPENDS_${PN} += "python python-io python-lang python-subprocess python-resource"
-SRCBRANCH = "next"
-SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code;branch=${SRCBRANCH} \
+SRCREV = "ea3f6b273f535aab38cefae30030774457bbbfe6"
+SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \
file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \
- file://fix-lib64-can-not-be-shiped-in-64bit-target.patch \
file://tests-Makefile-install-static-4G-edge-testcases.patch \
file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \
- file://0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch \
+ file://0001-aarch64-fix-cross-compilation.patch \
+ file://0001-aarch64-fix-page-size-not-properly-computed.patch \
+ file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
"
-SRCREV = "6824d18d5f33fdab445a8eff147fcdb6361f5791"
S = "${WORKDIR}/git"
COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64).*-linux*"
-
-EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' BUILDTYPE=NATIVEONLY ${LIBARGS}"
+LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
+EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1"
CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"
TARGET_CC_ARCH += "${LDFLAGS}"
@@ -31,6 +31,9 @@ do_configure() {
if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile
fi
+
+ # fixup perl module directory hardcoded to perl5
+ sed -i 's/perl5/perl/g' Makefile
}
do_install() {