aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-07-15 07:26:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:48 +0200
commitcd45cd77ef6868e515018ee8feac6c30490fb8d3 (patch)
tree88dc21d5158afc230d4862e12b764874fba311a9 /meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
parent7b6c734be688432a21441660f482df6c1dacc657 (diff)
downloadmeta-openembedded-contrib-cd45cd77ef6868e515018ee8feac6c30490fb8d3.tar.gz
libhugetlbfs: fix packaging
Libhugetlbs doesn't generate proper .so.X libs, only two .so files. Package those in ${PN} and silence the resulting QA warning. This fixes: ERROR: QA Issue: libhugetlbfs-tests rdepends on libhugetlbfs-dev Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 16dc928bc4..e8e078721b 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -26,6 +26,7 @@ COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1"
+PARALLEL_MAKE = ""
CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"
TARGET_CC_ARCH += "${LDFLAGS}"
@@ -47,12 +48,15 @@ do_install() {
install-tests
}
-PARALLEL_MAKE_pn-${PN} = ""
PACKAGES =+ "${PN}-perl ${PN}-tests "
+FILES_${PN} += "${libdir}/*.so"
+FILES_${PN}-dev = "${includedir}"
FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
FILES_${PN}-perl = "${libdir}/perl"
FILES_${PN}-tests += "${libdir}/libhugetlbfs/tests"
+INSANE_SKIP_${PN} = "dev-so"
+
INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"