aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-07-16 14:23:59 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:48 +0200
commit3efa07753667e011e417daea59c3052f47e2e030 (patch)
treecda3d808e62ed8b907eac725a9be83e7fcef7de3 /meta-oe/recipes-benchmark
parentcd45cd77ef6868e515018ee8feac6c30490fb8d3 (diff)
downloadmeta-openembedded-contrib-3efa07753667e011e417daea59c3052f47e2e030.tar.gz
libhugetlbfs: use ARCH ppc/ppc64 for powerpc/powerpc64
In recent libhugetlbfs source, powerpc/powerpc64 is changed back to ppc/ppc64 (to match with the output of `uname -a`). Update the recipe to avoid build issue for now. Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index e8e078721b..e554b26c2f 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -25,7 +25,10 @@ S = "${WORKDIR}/git"
COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
-EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1"
+LIBHUGETLBFS_ARCH = "${TARGET_ARCH}"
+LIBHUGETLBFS_ARCH_powerpc = "ppc"
+LIBHUGETLBFS_ARCH_powerpc64 = "ppc64"
+EXTRA_OEMAKE = "'ARCH=${LIBHUGETLBFS_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=2"
PARALLEL_MAKE = ""
CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"