aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-07-16 14:24:00 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:48 +0200
commitcd63a38d0ac5daabdbf12ba13c20b492b37ac70e (patch)
treeaead8c241f24740b676480f64884549d5c36a240 /meta-oe/recipes-benchmark
parent3efa07753667e011e417daea59c3052f47e2e030 (diff)
downloadmeta-openembedded-contrib-cd63a38d0ac5daabdbf12ba13c20b492b37ac70e.tar.gz
libhugetlbfs: not build obj32 for powerpc64
If obj32 needed, user can build lib32-libhugetlbfs. Fix the below build issue for 64bit powerpc boards: | fatal error: gnu/stubs-32.h: No such file or directory | # include <gnu/stubs-32.h> | ^ | compilation terminated. | make: *** [obj32/elflink.o] Error 1 Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index e554b26c2f..55d555b5f9 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -29,6 +29,7 @@ LIBHUGETLBFS_ARCH = "${TARGET_ARCH}"
LIBHUGETLBFS_ARCH_powerpc = "ppc"
LIBHUGETLBFS_ARCH_powerpc64 = "ppc64"
EXTRA_OEMAKE = "'ARCH=${LIBHUGETLBFS_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=2"
+EXTRA_OEMAKE_append_powerpc64 = " BUILDTYPE=NATIVEONLY"
PARALLEL_MAKE = ""
CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"