aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:42:28 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:04 +0200
commitfd84ec341f3224e1f79f185588f2cd844f464f86 (patch)
tree3e9f708a4f3554c2ef4c636ab199aa295a237dc7 /meta-oe/recipes-connectivity
parentf2b3287cc162169028ad59e9fc5ebde8e03cbb04 (diff)
downloadmeta-openembedded-contrib-fd84ec341f3224e1f79f185588f2cd844f464f86.tar.gz
cherokee: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service10
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb16
2 files changed, 23 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
new file mode 100644
index 0000000000..a2d703185d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Cherokee web server
+After=syslog.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/cherokee -d -C /etc/cherokee/cherokee.conf
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
index 84d6dce32d..422ebdab40 100644
--- a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
@@ -5,16 +5,18 @@ SECTION = "network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r6"
+PR = "r9"
DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \
- file://cherokee.init"
+ file://cherokee.init \
+ file://cherokee.service \
+"
SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
-inherit autotools pkgconfig binconfig update-rc.d
+inherit autotools pkgconfig binconfig update-rc.d systemd
EXTRA_OECONF = "--disable-static \
--disable-nls \
@@ -27,6 +29,9 @@ do_install_append () {
# clean up .la files for plugins
rm -f ${D}${libdir}/cherokee/*.la
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
}
# Put -dev near the front so we can move the .la files into it with a wildcard
@@ -44,3 +49,8 @@ CONFFILES_${PN} = " \
INITSCRIPT_NAME = "cherokee"
INITSCRIPT_PARAMS = "defaults 91 91"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "cherokee.service"