aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorlumag <dbaryshkov@gmail.com>2011-09-05 01:37:03 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-06 12:24:38 +0200
commitcffa06f750b720f3e2391b104c4be533fc61feec (patch)
tree938e37fe3d6d2a857302b0396a0207f128236a8a /meta-oe/recipes-connectivity
parentc17fe9bc7ed4096853ba160a67300b3c5e1dd02b (diff)
downloadmeta-openembedded-contrib-cffa06f750b720f3e2391b104c4be533fc61feec.tar.gz
openssl: fully fix parallel builds
Add a patch from oe-core to fix parallel builds in openssl 0.9.8m. Then drop PARALLEL_MAKE settings in both of recipes. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch20
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb3
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb1
3 files changed, 21 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch b/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch
new file mode 100644
index 0000000000..82857f5744
--- /dev/null
+++ b/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch
@@ -0,0 +1,20 @@
+Upstream-Status: Submitted
+
+fix the parallel build regarding shared libraries.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/Makefile.org b/Makefile.org
+index 2fb0309..8bec3d0 100644
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -352,6 +352,9 @@ all_testapps: build_libs build_testapps
+ build_testapps:
+ @dir=crypto; target=testapps; $(BUILD_ONE_CMD)
+
++libcrypto.a: build_crypto
++libssl.a: build_ssl
++
+ build_shared: $(SHARED_LIBS)
+ libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS)
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
diff --git a/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb b/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb
index a7eb332857..1091bf2ed3 100644
--- a/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb
+++ b/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb
@@ -11,6 +11,5 @@ export OE_LDFLAGS="${LDFLAGS}"
SRC_URI += "file://configure-targets.patch \
file://shared-libs.patch \
file://debian.patch \
+ file://parallel-make-fix.patch \
file://oe-ldflags.patch"
-
-PARALLEL_MAKE = ""
diff --git a/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb b/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb
index 89b8615999..63b5460de4 100644
--- a/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb
+++ b/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb
@@ -41,6 +41,5 @@ PACKAGES += " \
${PN}-engines-dbg \
"
-PARALLEL_MAKE = ""
FILES_${PN}-engines = "${libdir}/ssl/engines/*.so"
FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"