summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-18 17:27:20 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-19 20:41:26 +0200
commitce196cc366bf9e5b96463277a14c39b6de33c583 (patch)
tree27fa471acdf653f141c9b3902079110db0bdec23 /meta-oe/recipes-connectivity
parent292abf0fd33d3ee0bff3c72e7d7edab026bdeda5 (diff)
downloadmeta-openembedded-contrib-ce196cc366bf9e5b96463277a14c39b6de33c583.tar.gz
midori: add 0.3.6
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/midori/midori/speeddial.patch35
-rw-r--r--meta-oe/recipes-connectivity/midori/midori_0.3.6.bb11
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/midori/midori/speeddial.patch b/meta-oe/recipes-connectivity/midori/midori/speeddial.patch
new file mode 100644
index 0000000000..ba436a2b66
--- /dev/null
+++ b/meta-oe/recipes-connectivity/midori/midori/speeddial.patch
@@ -0,0 +1,35 @@
+From 7f549b89a9e9939a7888d9e4ede628ef9c80df80 Mon Sep 17 00:00:00 2001
+From: Christian Dywan <christian@twotoasts.de>
+Date: Fri, 20 May 2011 19:58:35 +0000
+Subject: Handle missing speedial.json and missing shortcuts array
+
+---
+diff --git a/midori/main.c b/midori/main.c
+index 007b03f..c6b8568 100644
+--- a/midori/main.c
++++ b/midori/main.c
+@@ -1605,7 +1605,12 @@ speeddial_new_from_file (const gchar* config,
+ }
+
+ katze_assign (config_file, g_build_filename (config, "speeddial.json", NULL));
+- g_file_get_contents (config_file, &json_content, &json_length, NULL);
++ if (!g_file_get_contents (config_file, &json_content, &json_length, NULL))
++ {
++ katze_assign (json_content, g_strdup ("'{}'"));
++ json_length = strlen ("'{}'");
++ }
++
+ script = g_string_sized_new (json_length);
+ g_string_append (script, "var json = JSON.parse (");
+ g_string_append_len (script, json_content, json_length);
+@@ -1619,7 +1624,7 @@ speeddial_new_from_file (const gchar* config,
+ " + 'title=' + tile['title'] + '\\n\\n';"
+ "} "
+ "var columns = json['width'] ? json['width'] : 3;"
+- "var rows = json['shortcuts'].length / columns;"
++ "var rows = json['shortcuts'] ? json['shortcuts'].length / columns : 0;"
+ "keyfile += '[settings]\\n'"
+ " + 'columns=' + columns + '\\n'"
+ " + 'rows=' + (rows > 3 ? rows : 3) + '\\n\\n';"
+--
+cgit
diff --git a/meta-oe/recipes-connectivity/midori/midori_0.3.6.bb b/meta-oe/recipes-connectivity/midori/midori_0.3.6.bb
new file mode 100644
index 0000000000..33fa5e69dc
--- /dev/null
+++ b/meta-oe/recipes-connectivity/midori/midori_0.3.6.bb
@@ -0,0 +1,11 @@
+require midori.inc
+
+PR = "r1"
+
+SRC_URI = "http://archive.xfce.org/src/apps/midori/0.3/midori-${PV}.tar.bz2;name=midori \
+ file://speeddial.patch \
+ "
+SRC_URI[midori.md5sum] = "c4cb0686601b1c470c317de3d3f8e8fd"
+SRC_URI[midori.sha256sum] = "5fb290ffde81e5e6b39a54d286f5732496bfda10ff65019189cc6bf8408f2410
+
+