aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorNick Lewis <nick.lewis@usa.g4s.com>2014-01-06 17:16:03 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-11 14:58:49 +0100
commitfef89c60f381d52ddcbcf557b4082ed46233906c (patch)
treeb66fe7618234a4ae30963e82401c56b7cd1380c5 /meta-oe/recipes-core
parent94de3cef65e9fca0838d95ab8d32153ba7bcc4ed (diff)
downloadmeta-openembedded-contrib-fef89c60f381d52ddcbcf557b4082ed46233906c.tar.gz
libxml++: Upgrade to 2.37.1 and add ptest support
Signed-off-by: Nick Lewis <nick.lewis@usa.g4s.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch73
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest3
-rw-r--r--meta-oe/recipes-core/libxml/libxml++_2.37.1.bb (renamed from meta-oe/recipes-core/libxml/libxml++_2.35.3.bb)20
3 files changed, 89 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
new file mode 100644
index 0000000000..a18822f724
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
@@ -0,0 +1,73 @@
+diff --git a/Makefile.am b/Makefile.am
+index d4aadb1..0e36756 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -253,5 +253,8 @@ post-html: docs/index.html
+ rsync $(rsync_args) -r docs/index.html $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project)
+ rsync $(rsync_args) -r examples $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project)
+
++install-ptest:
++ make -C examples install-ptest
++
+ # Optional: auto-generate the ChangeLog file from the git log on make dist
+ include $(top_srcdir)/macros/dist-changelog.am
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index d9541ca..c28b49c 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -36,6 +36,23 @@ check_PROGRAMS = \
+ schemavalidation/schemavalidation \
+ textreader/textreader
+
++check_DOTLIBS = \
++ dom_build/.libs/dom_build \
++ dom_parse_entities/.libs/dom_parse_entities \
++ dom_parser/.libs/dom_parser \
++ dom_parser_raw/.libs/dom_parser_raw \
++ dom_read_write/.libs/dom_read_write \
++ dom_xinclude/.libs/dom_xinclude \
++ dom_xpath/.libs/dom_xpath \
++ dtdvalidation/.libs/dtdvalidation \
++ import_node/.libs/import_node \
++ sax_exception/.libs/sax_exception \
++ sax_parser/.libs/sax_parser \
++ sax_parser_build_dom/.libs/sax_parser_build_dom \
++ sax_parser_entities/.libs/sax_parser_entities \
++ schemavalidation/.libs/schemavalidation \
++ textreader/.libs/textreader
++
+ # Shell scripts that call the example programs.
+ check_SCRIPTS = \
+ dom_build/make_check.sh \
+@@ -147,10 +164,10 @@ dist_noinst_DATA = \
+ # file are located in different directories.
+ dom_read_write/make_check.sh: Makefile
+ echo '# Generated and used by "make check"' >$@
+- echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
++ echo 'dom_read_write/.libs/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
+ chmod +x $@
+
+-script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null
++script_template = cd "$(srcdir)/<!progname!>" && ".libs/<!progname!>" >/dev/null
+ standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS))
+
+ # All other script files are generated like so:
+@@ -162,3 +179,18 @@ $(standard_scripts): Makefile
+ CLEANFILES = \
+ dom_read_write/example_output.xml \
+ $(check_SCRIPTS)
++
++buildtest: all
++ $(MAKE) $(AM_MAKEFLAGS) $(check_PROGRAMS) $(check_SCRIPTS)
++ $(MAKE) $(AM_MAKEFLAGS) buildtest-TESTS
++
++install-ptest:
++ $(MKDIR_P) $(DESTDIR)/examples
++ cp --parents $(check_DOTLIBS) $(DESTDIR)/examples
++ cp --parents $(check_SCRIPTS) $(DESTDIR)/examples
++ cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
++ cp Makefile $(DESTDIR)/examples
++ $(MKDIR_P) $(DESTDIR)/macros
++ cp ../macros/test-driver $(DESTDIR)/macros
++ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile
++
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest b/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest
new file mode 100644
index 0000000000..236f667538
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd examples
+make -k check-TESTS
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.35.3.bb b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
index fb9cdd9547..0ed8ee3992 100644
--- a/meta-oe/recipes-core/libxml/libxml++_2.35.3.bb
+++ b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
@@ -6,17 +6,23 @@ SECTION = "libs"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 "
-PR = "r1"
-
SHRT_VER = "${@d.getVar('PV',True).split('.')[0]}.${@d.getVar('PV',True).split('.')[1]}"
-SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz"
-
-SRC_URI[md5sum] = "196a2dcdc84ab987fe3852b3f29cafd7"
-SRC_URI[sha256sum] = "715a4214bbff90365cc8406a28e427febd90461006d608fbdcdcea7fc9891eaf"
+SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
+ file://libxml++_ptest.patch \
+ file://run-ptest \
+"
+SRC_URI[md5sum] = "2f9372a6eba6e40206c11f558a8fbc32"
+SRC_URI[sha256sum] = "f3b183600532a92af355719210223f858857092b8b1531c7907155c59a6db39f"
DEPENDS = "libxml2 glibmm"
-inherit autotools pkgconfig
+inherit autotools pkgconfig ptest
+
+do_compile_ptest() {
+ oe_runmake -C examples buildtest
+}
FILES_${PN}-doc += "${datadir}/devhelp"
FILES_${PN}-dev += "${libdir}/libxml++-2.6/include/libxml++config.h"
+
+RDEPENDS_${PN}-ptest += "make"