aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-03-06 01:12:58 -0800
committerKhem Raj <raj.khem@gmail.com>2019-03-07 09:33:45 -0800
commit5173929d7f974943110fc28814c49931e14a81c5 (patch)
tree3afe163462f360ef7d39564b408418946f9862ad /meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
parent14bf885618c426b018a6af8ff6cd7160d3fc1747 (diff)
downloadmeta-openembedded-contrib-5173929d7f974943110fc28814c49931e14a81c5.tar.gz
mysql-python: fix compilation with MariaDB 10.3.13
Use standard API function MYSQL_OPT_RECONNECT instead of direct modification of internal structures which does not work for MariaDB to fix below compile issue. | _mysql.c: In function '_mysql_ConnectionObject_ping': | _mysql.c:2005:41: error: 'MYSQL' {aka 'struct st_mysql'} has no member named 'reconnect' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb')
-rw-r--r--meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
index ac0df4f066..f2faec1c13 100644
--- a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
+++ b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
@@ -8,7 +8,9 @@ DEPENDS = "mysql5"
SRCNAME = "MySQL-python"
-SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.zip"
+SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.zip \
+ file://0001-_mysql.c-fix-compilation-with-MariaDB-with-10.3.13.patch \
+"
SRC_URI[md5sum] = "654f75b302db6ed8dc5a898c625e030c"
SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e140c74"