aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/rocksdb/files/0001-CMake-has-stock-FindZLIB-in-upper-case.patch
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2019-06-12 10:16:05 +0200
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commitcaa50b113e627e9c05ebc78df56cc9e3584311c3 (patch)
treebc080bc0dab14be5b7532b88ffbe49918ce25771 /meta-oe/recipes-dbs/rocksdb/files/0001-CMake-has-stock-FindZLIB-in-upper-case.patch
parent5e9bf7ea8f11b9b32664aa8543a5f3dec383700d (diff)
downloadmeta-openembedded-contrib-caa50b113e627e9c05ebc78df56cc9e3584311c3.tar.gz
rocksdb: 5.18.3 -> 6.0.2
Also add support for gflags as these are enabled by default and recipes are available in meta-oe. They can still be disabled via PACKAGECONFIG. zstd is also added as an PACKAGECONFIG but currently the zstd recipe is not in meta-oe so it stays disabled for the moment. This also includes a patch that fixes GCC9 compatibility, it's currently submitted upstream but not yet accepted due to style issues. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/rocksdb/files/0001-CMake-has-stock-FindZLIB-in-upper-case.patch')
-rw-r--r--meta-oe/recipes-dbs/rocksdb/files/0001-CMake-has-stock-FindZLIB-in-upper-case.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/rocksdb/files/0001-CMake-has-stock-FindZLIB-in-upper-case.patch b/meta-oe/recipes-dbs/rocksdb/files/0001-CMake-has-stock-FindZLIB-in-upper-case.patch
new file mode 100644
index 0000000000..9682f8ad40
--- /dev/null
+++ b/meta-oe/recipes-dbs/rocksdb/files/0001-CMake-has-stock-FindZLIB-in-upper-case.patch
@@ -0,0 +1,29 @@
+From 38146a5d803a1fb9b10f011aa857872b6f20cd02 Mon Sep 17 00:00:00 2001
+From: Tongliang Liao <xkszltl@gmail.com>
+Date: Mon, 29 Apr 2019 03:51:51 -0700
+Subject: [PATCH] CMake has stock FindZLIB in upper case. More details in
+ https://cmake.org/cmake/help/v3.14/module/FindZLIB.html
+
+
+Upstream-Status: Backport https://github.com/facebook/rocksdb/pull/5261
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 40cdd26bb..355686566 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,7 +92,7 @@ else()
+ endif()
+
+ if(WITH_ZLIB)
+- find_package(zlib REQUIRED)
++ find_package(ZLIB REQUIRED)
+ add_definitions(-DZLIB)
+ if(ZLIB_INCLUDE_DIRS)
+ # CMake 3
+--
+2.11.0
+